summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-01 05:37:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-01 05:37:08 +0000
commit35ffe8d656b06166f0cf0de85f017ed495b29820 (patch)
treed1513893e2f1c42110b4a589ee1a098645a5d5d4 /games-server
parentinitial ebuild #40979 (diff)
downloadhistorical-35ffe8d656b06166f0cf0de85f017ed495b29820.tar.gz
historical-35ffe8d656b06166f0cf0de85f017ed495b29820.tar.bz2
historical-35ffe8d656b06166f0cf0de85f017ed495b29820.zip
make ${GAMES_STATEDIR}/pvpgn in src_install; error check; error messages; tidy
Diffstat (limited to 'games-server')
-rw-r--r--games-server/pvpgn/ChangeLog5
-rw-r--r--games-server/pvpgn/Manifest16
-rw-r--r--games-server/pvpgn/pvpgn-1.6.5.ebuild41
3 files changed, 28 insertions, 34 deletions
diff --git a/games-server/pvpgn/ChangeLog b/games-server/pvpgn/ChangeLog
index 49e6a537a94d..53c563be1e71 100644
--- a/games-server/pvpgn/ChangeLog
+++ b/games-server/pvpgn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-server/pvpgn
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/pvpgn/ChangeLog,v 1.1 2004/09/01 04:39:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/pvpgn/ChangeLog,v 1.2 2004/09/01 05:37:08 mr_bones_ Exp $
+
+ 31 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> pvpgn-1.6.5.ebuild:
+ make ${GAMES_STATEDIR}/pvpgn in src_install; error check; error messages; tidy
*pvpgn-1.6.5 (01 Sep 2004)
diff --git a/games-server/pvpgn/Manifest b/games-server/pvpgn/Manifest
index 528b7e310c23..d85ee66ab3e5 100644
--- a/games-server/pvpgn/Manifest
+++ b/games-server/pvpgn/Manifest
@@ -1,16 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 26cca527242ae2cc658a70534b03d5b9 pvpgn-1.6.5.ebuild 2341
+MD5 ed88483e63b94771bb6c0ba143ca8707 ChangeLog 507
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 3c8456f79715fb8b848e471e99ca0b7d ChangeLog 347
+MD5 d501aa694a38468a7b78a9c3f669b3b0 pvpgn-1.6.5.ebuild 2435
+MD5 778be818c35e7df1e022398198427172 files/1.6.5-fhs.patch 10322
MD5 ba5db7daf3b6cfeb5c463b3d8f7ee32b files/digest-pvpgn-1.6.5 134
MD5 0dea305044e123e1b1ee007331906727 files/init.d.rc 785
-MD5 778be818c35e7df1e022398198427172 files/1.6.5-fhs.patch 10322
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBNVKgHTu7gpaalycRAi4yAKDOZz5+fYtq6bB0LsoiC3fA6Fx9+QCeNbBN
-7+HaA0c+fHu3Nk4RReDs+28=
-=1rTy
------END PGP SIGNATURE-----
diff --git a/games-server/pvpgn/pvpgn-1.6.5.ebuild b/games-server/pvpgn/pvpgn-1.6.5.ebuild
index 9c947b3a0340..db5b66e9dc12 100644
--- a/games-server/pvpgn/pvpgn-1.6.5.ebuild
+++ b/games-server/pvpgn/pvpgn-1.6.5.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/pvpgn/pvpgn-1.6.5.ebuild,v 1.1 2004/09/01 04:39:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/pvpgn/pvpgn-1.6.5.ebuild,v 1.2 2004/09/01 05:37:08 mr_bones_ Exp $
inherit games
-SP="pvpgn-support-1.0"
+SUPPORTP="pvpgn-support-1.0"
DESCRIPTION="A gaming server for Battle.Net compatible clients"
HOMEPAGE="http://www.pvpgn.org/"
SRC_URI="mirror://sourceforge/pvpgn/${P}.tar.bz2
- mirror://sourceforge/pvpgn/${SP}.tar.gz"
+ mirror://sourceforge/pvpgn/${SUPPORTP}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -22,17 +22,17 @@ DEPEND="virtual/libc
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-fhs.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-fhs.patch"
}
src_compile() {
cd src
egamesconf \
- `use_with mysql` \
- `use_with postgres pgsql` \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
|| die
- emake || die "compile problem"
+ emake || die "emake failed"
}
src_install() {
@@ -41,32 +41,33 @@ src_install() {
dodoc docs/*
cd src
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
- insinto ${GAMES_DATADIR}/pvpgn
- doins ${WORKDIR}/${SP}/*
+ insinto "${GAMES_DATADIR}/pvpgn"
+ doins "${WORKDIR}/${SUPPORTP}/"* || die "doins failed"
exeinto /etc/init.d
local f
for f in bnetd d2cs d2dbs ; do
- newexe ${FILESDIR}/init.d.rc ${f}
+ newexe "${FILESDIR}/init.d.rc" ${f}
sed -i \
-e "s:NAME:${f}:g" \
-e "s:GAMES_BINDIR:${GAMES_BINDIR}:g" \
-e "s:GAMES_USER:${GAMES_USER}:g" \
-e "s:GAMES_GROUP:${GAMES_GROUP}:g" \
- ${D}/etc/init.d/${f}
+ "${D}/etc/init.d/${f}" \
+ || die "sed ${D}/etc/init.d/${f} failed"
done
prepgamesdirs
+ keepdir "${GAMES_STATEDIR}/pvpgn/log"
+ chown -R ${GAMES_USER}:${GAMES_GROUP} "${D}${GAMES_STATEDIR}/pvpgn"
+ fperm 0755 "${GAMES_STATEDIR}/pvpgn/log"
+ fperm 0750 "${GAMES_STATEDIR}/pvpgn"
}
pkg_postinst() {
- einfo "Setting up permissions on ${GAMES_STATEDIR}/pvpgn"
- mkdir -p ${GAMES_STATEDIR}/pvpgn/log
- chmod 0755 ${GAMES_STATEDIR}/pvpgn/log
- chown -R ${GAMES_USER}:${GAMES_GROUP} ${GAMES_STATEDIR}/pvpgn
- chmod 0750 ${GAMES_STATEDIR}/pvpgn
+ games_pkg_postinst
einfo " If this is a first installation you have to configure package by"
einfo "editing the configuration files provided in \"${GAMES_SYSCONFDIR}/pvpgn\". Also you"
@@ -75,12 +76,12 @@ pkg_postinst() {
einfo " If you are upgrading you MUST read /usr/share/docs/${P}/UPDATE.gz"
einfo "and update your configuration acordingly."
if use mysql ; then
- einfo
+ echo
einfo " You have enabled MySQL storage support. You will need to edit "
einfo "bnetd.conf to use it. Read README.storage from the docs dir."
fi
if use postgres ; then
- einfo
+ echo
einfo " You have enabled PostgreSQL storage support. You will need to edit "
einfo "bnetd.conf to use it. Read README.storage from the docs dir."
fi