summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-13 22:07:17 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-13 22:07:17 +0000
commit9c6b931c1f766032b410ab039642bfb5674b79a8 (patch)
treefeab65a92af20cb3008e4ccb046956b9f5d71eeb /games-server/hlstats
parentinitial import (diff)
downloadhistorical-9c6b931c1f766032b410ab039642bfb5674b79a8.tar.gz
historical-9c6b931c1f766032b410ab039642bfb5674b79a8.tar.bz2
historical-9c6b931c1f766032b410ab039642bfb5674b79a8.zip
ver bump #30990
Diffstat (limited to 'games-server/hlstats')
-rw-r--r--games-server/hlstats/ChangeLog7
-rw-r--r--games-server/hlstats/files/digest-hlstats-1.201
-rw-r--r--games-server/hlstats/hlstats-1.20.ebuild70
3 files changed, 77 insertions, 1 deletions
diff --git a/games-server/hlstats/ChangeLog b/games-server/hlstats/ChangeLog
index 5c3c227458b7..10603dbb3002 100644
--- a/games-server/hlstats/ChangeLog
+++ b/games-server/hlstats/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-server/hlstats
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/ChangeLog,v 1.2 2003/09/10 15:49:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/ChangeLog,v 1.3 2003/10/13 22:07:17 vapier Exp $
+
+*hlstats-1.20 (13 Oct 2003)
+
+ 13 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #30990.
*hlstats-1.02 (09 Jul 2003)
diff --git a/games-server/hlstats/files/digest-hlstats-1.20 b/games-server/hlstats/files/digest-hlstats-1.20
new file mode 100644
index 000000000000..9f103b801f60
--- /dev/null
+++ b/games-server/hlstats/files/digest-hlstats-1.20
@@ -0,0 +1 @@
+MD5 ebea3784d7798fa44cea38b969f2644d hlstats-1.20.tar.gz 1075534
diff --git a/games-server/hlstats/hlstats-1.20.ebuild b/games-server/hlstats/hlstats-1.20.ebuild
new file mode 100644
index 000000000000..756b5f681a87
--- /dev/null
+++ b/games-server/hlstats/hlstats-1.20.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/hlstats/hlstats-1.20.ebuild,v 1.1 2003/10/13 22:07:17 vapier Exp $
+
+inherit games
+
+DESCRIPTION="real-time player rankings/statistics for half-life"
+HOMEPAGE="http://www.hlstats.org/"
+SRC_URI="mirror://sourceforge/hlstats/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="dev-lang/perl
+ dev-db/mysql
+ net-www/apache
+ dev-php/mod_php"
+
+src_install() {
+ dodoc ChangeLog
+
+ insinto ${GAMES_LIBDIR}/${PN}
+ doins *.{pm,plib}
+
+ insinto ${GAMES_DATADIR}/${PN}
+ doins *.sql
+
+ sed -i \
+ -e "s:\./hlstats\.conf:${GAMES_SYSCONFDIR}/hlstats.conf:" \
+ -e "/^\$opt_libdir =/s:=.*:=\"${GAMES_LIBDIR}/${PN}/\";:" \
+ *.pl
+ dogamesbin *.pl
+ dobin ${FILESDIR}/hlstats
+ dosed "s:GENTOO_DIR:${GAMES_BINDIR}:" /usr/bin/hlstats
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hlstats.rc hlstats
+
+ insinto ${GAMES_SYSCONFDIR}
+ doins hlstats.conf
+
+ dodir /home/httpd/htdocs
+ cp -r hlstats.php hlstatsimg hlstatsinc ${D}/home/httpd/htdocs/
+
+ #prepgamesdirs # let apache own the files
+}
+
+pkg_postinst() {
+ einfo "To setup:"
+ einfo " 1. \`mysqladmin create hlstats\`"
+ einfo " 2. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/hlstats.sql\`"
+ einfo " 3. \`mysql hlstats < ${GAMES_DATADIR}/${PN}/gamesupport_GAME.sql\`"
+ einfo " so if you want cstrike support, replace 'GAME' with 'cstrike'"
+ einfo " 4. Edit ${GAMES_SYSCONFDIR}/hlstats.conf"
+ einfo " 5. Edit /home/httpd/htdocs/hlstats.php"
+ einfo " 6. \`rc-update add hlstats default\`"
+ einfo " 7. \`/etc/init.d/hlstats start\`"
+ einfo " 8. Edit the cfg files of the game servers you want to track ..."
+ einfo " add these lines to your config file:"
+ einfo " log on"
+ einfo " logaddress 1.2.3.4 27500"
+ einfo " (replace 1.2.3.4 with the IP of the server hlstats is running on)"
+ einfo " 9. If you want daily awards, setup a cronjob to run hlstats-awards.pl"
+ einfo " for example, run \`crontab -e\` and add this entry:"
+ einfo " 30 00 * * * ${GAMES_BINDIR}/hlstats-awards.pl"
+ einfo " 10. Finally ! Start up the server and after a while goto"
+ einfo " http://1.2.3.4/hlstats.php"
+ einfo " (replace 1.2.3.4 with the IP of the server hlstats is running on)"
+}