summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-17 23:42:49 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-17 23:42:49 +0000
commit9693e4edaaffdd539ab15150ed4fd94889723e97 (patch)
treebfc7c6af91f2b62918efe4c0ad91125d12b07efa /games-server/halflife-server
parentcleanup (diff)
downloadhistorical-9693e4edaaffdd539ab15150ed4fd94889723e97.tar.gz
historical-9693e4edaaffdd539ab15150ed4fd94889723e97.tar.bz2
historical-9693e4edaaffdd539ab15150ed4fd94889723e97.zip
add boffix
Diffstat (limited to 'games-server/halflife-server')
-rw-r--r--games-server/halflife-server/files/3.1.1.0-hlds_run-boffix.patch10
-rw-r--r--games-server/halflife-server/files/digest-halflife-server-3.1.1.01
-rw-r--r--games-server/halflife-server/halflife-server-3.1.1.0.ebuild9
3 files changed, 18 insertions, 2 deletions
diff --git a/games-server/halflife-server/files/3.1.1.0-hlds_run-boffix.patch b/games-server/halflife-server/files/3.1.1.0-hlds_run-boffix.patch
new file mode 100644
index 000000000000..86fe67b17734
--- /dev/null
+++ b/games-server/halflife-server/files/3.1.1.0-hlds_run-boffix.patch
@@ -0,0 +1,10 @@
+--- hlds_run.orig 2003-12-17 18:38:03.000000000 -0500
++++ hlds_run 2003-12-17 18:38:15.000000000 -0500
+@@ -17,6 +17,7 @@
+ #trap "" SIGINT
+
+ # setup the libraries, local dir first!
++export LD_PRELOAD=./boffix_i386.so
+ export LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH
+ if test -n "`echo $* | grep "\-norestart"`" ; then
+ RESTART=""; # norestart defined, do do restarts
diff --git a/games-server/halflife-server/files/digest-halflife-server-3.1.1.0 b/games-server/halflife-server/files/digest-halflife-server-3.1.1.0
index 37fcdefba356..2d22310a5fa7 100644
--- a/games-server/halflife-server/files/digest-halflife-server-3.1.1.0
+++ b/games-server/halflife-server/files/digest-halflife-server-3.1.1.0
@@ -1 +1,2 @@
MD5 4bf86966424dedc686cdf63c72c1913d hlds_l_3110_full.bin 120884265
+MD5 2dcf56fbbe1ad52c46e5d4db4fd76cbd boffix_v3.tar.gz 6786
diff --git a/games-server/halflife-server/halflife-server-3.1.1.0.ebuild b/games-server/halflife-server/halflife-server-3.1.1.0.ebuild
index 26316db70b90..f19687e8b180 100644
--- a/games-server/halflife-server/halflife-server-3.1.1.0.ebuild
+++ b/games-server/halflife-server/halflife-server-3.1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-server/halflife-server-3.1.1.0.ebuild,v 1.4 2003/11/30 11:41:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-server/halflife-server-3.1.1.0.ebuild,v 1.5 2003/12/17 23:42:35 vapier Exp $
inherit games eutils
@@ -8,7 +8,7 @@ MY_PV=${PV//.}
MY_PN=hlds_l_${MY_PV}_full
DESCRIPTION="Halflife Linux Server"
HOMEPAGE="http://www.valve.com/"
-SRC_URI="${MY_PN}.bin"
+SRC_URI="${MY_PN}.bin boffix_v3.tar.gz"
LICENSE="ValveServer"
SLOT="0"
@@ -23,6 +23,8 @@ S=${WORKDIR}/hlds_l
pkg_nofetch() {
einfo "Please goto fileplanet and d/l ${MY_BIN}"
einfo "http://www.fileplanet.com/files/50000/58368.shtml"
+ einfo "Then download boffix_v3.tar.gz from here:"
+ einfo "http://miklos.clanhost.dk/boffix_v3.tar.gz"
}
src_unpack() {
@@ -30,6 +32,9 @@ src_unpack() {
echo ">>> Unpacking ${MY_PN}.tar.gz to ${S}"
tar -zxf ${MY_PN}.tar.gz
rm ${MY_PN}.tar.gz
+ cd ${S}
+ unpack boffix_v3.tar.gz
+ epatch ${FILESDIR}/${PV}-hlds_run-boffix.patch
}
src_install() {