summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-02-20 11:41:59 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-02-20 11:41:59 +0000
commite543056d2cef27643b9feeae575b71722fb8d9bb (patch)
tree35642661036c624922eafcd9f8bd898f0a94a591 /games-rpg/nwmouse
parentalpha/ia64 stable wrt #210277 (diff)
downloadhistorical-e543056d2cef27643b9feeae575b71722fb8d9bb.tar.gz
historical-e543056d2cef27643b9feeae575b71722fb8d9bb.tar.bz2
historical-e543056d2cef27643b9feeae575b71722fb8d9bb.zip
Fixed bug #210562, thanks to Anton Romanov.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-rpg/nwmouse')
-rw-r--r--games-rpg/nwmouse/ChangeLog9
-rw-r--r--games-rpg/nwmouse/nwmouse-0.1-r1.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/games-rpg/nwmouse/ChangeLog b/games-rpg/nwmouse/ChangeLog
index 44fc564edd5b..ea9b24a20ea2 100644
--- a/games-rpg/nwmouse/ChangeLog
+++ b/games-rpg/nwmouse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/nwmouse
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/ChangeLog,v 1.6 2007/08/27 20:24:38 wolf31o2 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/ChangeLog,v 1.7 2008/02/20 11:39:39 calchan Exp $
+
+*nwmouse-0.1-r1 (20 Feb 2008)
+
+ 20 Feb 2008; Denis Dupeyron <calchan@gentoo.org> +nwmouse-0.1-r1.ebuild:
+ Fixed bug #210562, thanks to Anton Romanov.
27 Aug 2007; Chris Gianelloni <wolf31o2@gentoo.org> nwmouse-0.1.ebuild:
Stable on amd64/x86 for bug #190150.
diff --git a/games-rpg/nwmouse/nwmouse-0.1-r1.ebuild b/games-rpg/nwmouse/nwmouse-0.1-r1.ebuild
new file mode 100644
index 000000000000..da45c34eb6a3
--- /dev/null
+++ b/games-rpg/nwmouse/nwmouse-0.1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/nwmouse-0.1-r1.ebuild,v 1.1 2008/02/20 11:39:39 calchan Exp $
+
+inherit games
+
+DESCRIPTION="hardware mouse cursors for Neverwinter Nights"
+HOMEPAGE="http://home.woh.rr.com/nwmovies/nwmouse/"
+SRC_URI="http://home.woh.rr.com/nwmovies/cursors.tar.gz
+ http://dev.gentoo.org/~wolf31o2/sources/dump/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# I've looked at this stuff, and I can't find the problem myself, so I'm just
+# removing the warnings. If someone feels like finding the patch, that would be
+# great and I'll gladly include it.
+QA_EXECSTACK="${GAMES_PREFIX_OPT:1}/nwn/nwmouse.so"
+QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/nwn/nwmouse.so"
+IUSE=""
+RESTRICT="strip mirror"
+
+RDEPEND="sys-libs/glibc
+ games-rpg/nwn-data
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-sdl )
+ >=games-rpg/nwn-1.68-r4
+ x86? (
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libX11
+ media-libs/libsdl )"
+
+S="${WORKDIR}/${PN}"
+dir="${GAMES_PREFIX_OPT}/nwn"
+
+pkg_setup() {
+ games_pkg_setup
+ elog "This package is pre-compiled so it will work on both x86 and amd64."
+}
+
+src_unpack() {
+ unpack ${P}.tar.bz2 || die
+ mkdir "${S}"/cursors || die
+ cd "${S}"/cursors || die
+ unpack cursors.tar.gz || die
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe nwmouse.so || die
+ # libelf moved to games-rpg/nwn, see bug #210562
+ #exeinto "${dir}/lib"
+ #doexe libelf/libelf.so.1
+ exeinto "${dir}/nwmouse/libdis"
+ doexe libdis/libdisasm.so || die
+ insinto "${dir}/nwmouse/cursors"
+ doins cursors/* || die
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "When starting nwn the next time, nwmouse will scan the nwmain"
+ elog "binary for its hooks, store this information in:"
+ elog " ${dir}/nwmouse.ini"
+ elog "and exit. This is normal."
+ elog
+ elog "You will have to remove this file whenever you update nwn."
+}