summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-15 20:32:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-15 20:32:40 +0000
commit46ef9e583644bc74bdbb095b22e674aeb7286885 (patch)
tree856b7b5e17c059babceb6c3a585f4e7925076ffa /games-puzzle/tod
parentMarked Stable on AMD64 (diff)
downloadhistorical-46ef9e583644bc74bdbb095b22e674aeb7286885.tar.gz
historical-46ef9e583644bc74bdbb095b22e674aeb7286885.tar.bz2
historical-46ef9e583644bc74bdbb095b22e674aeb7286885.zip
tidy
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-puzzle/tod')
-rw-r--r--games-puzzle/tod/Manifest2
-rw-r--r--games-puzzle/tod/tod-0.ebuild17
2 files changed, 9 insertions, 10 deletions
diff --git a/games-puzzle/tod/Manifest b/games-puzzle/tod/Manifest
index 47689be42a5f..81efbefa6462 100644
--- a/games-puzzle/tod/Manifest
+++ b/games-puzzle/tod/Manifest
@@ -1,5 +1,5 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 2ed591d0d5f77c296de47fec2bc382a2 tod-0.ebuild 891
+MD5 7dda2da7330cfcace471c60695ed6c5a tod-0.ebuild 933
MD5 b0662b8b52fec11f76ffd1b664252e4a ChangeLog 339
MD5 83bc1cae0ee9d4d09b38cb2a013726d3 files/tod-0-makefile.patch 332
MD5 aaabc4fed4897548287b0533ee9239e2 files/digest-tod-0 55
diff --git a/games-puzzle/tod/tod-0.ebuild b/games-puzzle/tod/tod-0.ebuild
index dd4f458c0f90..c5c966ab1a41 100644
--- a/games-puzzle/tod/tod-0.ebuild
+++ b/games-puzzle/tod/tod-0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tod/tod-0.ebuild,v 1.2 2005/08/24 03:36:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tod/tod-0.ebuild,v 1.3 2005/09/15 20:32:40 mr_bones_ Exp $
inherit eutils games
@@ -13,7 +13,9 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE=""
-DEPEND="media-libs/allegro"
+RDEPEND="media-libs/allegro"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}
@@ -23,16 +25,13 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-makefile.patch
sed -i \
-e "s:idltd\.dat:${GAMES_DATADIR}/${PN}/idltd.dat:" \
- rec.c || die
-}
-
-src_compile() {
- emake -f makefile || die "make failed"
+ rec.c || die "sed failed"
}
src_install() {
- newgamesbin tod-debug.exe tod || die
+ newgamesbin tod-debug.exe tod || die "newgamesbin failed"
insinto "${GAMES_DATADIR}"/${PN}
- doins idltd.dat || die
+ doins idltd.dat || die "doins failed"
dodoc readme.txt
+ prepgamesdirs
}