summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-12 09:02:46 +0000
commitf193081a9f1537598f6fed550a0ec7b44c211741 (patch)
treeeda029f6c89b39343dfe7c3b970a3a8df8c0fcb0 /games-puzzle/gemdropx
parentnative widget stuff now also for gtk (diff)
downloadhistorical-f193081a9f1537598f6fed550a0ec7b44c211741.tar.gz
historical-f193081a9f1537598f6fed550a0ec7b44c211741.tar.bz2
historical-f193081a9f1537598f6fed550a0ec7b44c211741.zip
IUSE; error check; tidy
Diffstat (limited to 'games-puzzle/gemdropx')
-rw-r--r--games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild b/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild
index fdccfc91eed1..74ace849dfd4 100644
--- a/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild
+++ b/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild,v 1.3 2004/03/07 21:42:43 jhuebel Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild,v 1.4 2004/05/12 09:02:45 mr_bones_ Exp $
inherit games
@@ -11,6 +11,7 @@ SRC_URI="ftp://ftp.sonic.net/pub/users/nbs/unix/x/gemdropx/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc amd64"
+IUSE=""
DEPEND=">=media-libs/libsdl-1.2.3-r1
>=media-libs/sdl-mixer-1.2.1
@@ -18,15 +19,15 @@ DEPEND=">=media-libs/libsdl-1.2.3-r1
src_compile() {
emake \
- DATA_PREFIX=${GAMES_DATADIR}/${PN} \
+ DATA_PREFIX="${GAMES_DATADIR}/${PN}" \
XTRA_FLAGS="${CFLAGS}" \
- || die
+ || die "emake failed"
}
src_install() {
- dogamesbin gemdropx
- dodir ${GAMES_DATADIR}/${PN}
- cp -r data/* ${D}/${GAMES_DATADIR}/${PN}/
+ dogamesbin gemdropx || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r data/* "${D}/${GAMES_DATADIR}/${PN}/"
dodoc AUTHORS.txt CHANGES.txt ICON.txt README.txt TODO.txt
prepgamesdirs
}