summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-10 02:43:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-10 02:43:36 +0000
commitf831943b49e61eecb625c3da6e7681b869d68a9e (patch)
treea90cd4f9c44a3c17752ad1789fe9727ff1033e8a /games-misc
parentrepoman: Trim trailing whitespace (diff)
downloadhistorical-f831943b49e61eecb625c3da6e7681b869d68a9e.tar.gz
historical-f831943b49e61eecb625c3da6e7681b869d68a9e.tar.bz2
historical-f831943b49e61eecb625c3da6e7681b869d68a9e.zip
use games eclass; sed in unpack; more error checking/messages; Add metadata.xml
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/wtf/ChangeLog6
-rw-r--r--games-misc/wtf/Manifest5
-rw-r--r--games-misc/wtf/metadata.xml9
-rw-r--r--games-misc/wtf/wtf-20021005.ebuild22
4 files changed, 32 insertions, 10 deletions
diff --git a/games-misc/wtf/ChangeLog b/games-misc/wtf/ChangeLog
index 0fb8750a6b53..cc5a57ac3c31 100644
--- a/games-misc/wtf/ChangeLog
+++ b/games-misc/wtf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/wtf
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/wtf/ChangeLog,v 1.2 2003/09/10 20:25:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/wtf/ChangeLog,v 1.3 2003/11/10 02:43:34 mr_bones_ Exp $
+
+ 09 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> wtf-20021005.ebuild:
+ use games eclass; sed in unpack; more error checking/messages
+ Add metadata.xml
28 Jun 2003; <msterret@gentoo.org> wtf-20021005.ebuild:
use sed -i
diff --git a/games-misc/wtf/Manifest b/games-misc/wtf/Manifest
index 5903d46f40c8..7e3307b5d3c9 100644
--- a/games-misc/wtf/Manifest
+++ b/games-misc/wtf/Manifest
@@ -1,3 +1,4 @@
+MD5 6548b59260700ee944837a5a5b069804 ChangeLog 608
+MD5 f3bdbd6427cda89621853c5b9a317e7c wtf-20021005.ebuild 831
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
MD5 a3ea3a3414ac4359a2d9ab44931f0179 files/digest-wtf-20021005 62
-MD5 a274ee27d5c3111cc5c00565dcc26b1c wtf-20021005.ebuild 619
-MD5 f8ff5db09156e0a9efd746a0b2cec6e1 ChangeLog 445
diff --git a/games-misc/wtf/metadata.xml b/games-misc/wtf/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-misc/wtf/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-misc/wtf/wtf-20021005.ebuild b/games-misc/wtf/wtf-20021005.ebuild
index 74b3a58fa184..b527c5b0535d 100644
--- a/games-misc/wtf/wtf-20021005.ebuild
+++ b/games-misc/wtf/wtf-20021005.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/wtf/wtf-20021005.ebuild,v 1.1 2003/09/10 18:14:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/wtf/wtf-20021005.ebuild,v 1.2 2003/11/10 02:43:34 mr_bones_ Exp $
+
+inherit games
DESCRIPTION="translates acronyms for you"
HOMEPAGE="http://www.mu.org/~mux/wtf/"
@@ -11,14 +13,20 @@ SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa"
DEPEND=">=sys-apps/sed-4"
+RDEPEND="sys-apps/grep"
-src_compile() {
- sed -i -e 's:/local/:/:' wtf || die "sed wtf failed"
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e "s:/usr/local/share/misc:${GAMES_DATADIR}/${PN}:" \
+ ${S}/wtf || \
+ die "sed wtf failed"
}
src_install() {
- dobin wtf
- doman wtf.6
- insinto /usr/share/misc
- doins acronyms
+ dogamesbin wtf || die "dogamesbin failed"
+ doman wtf.6 || die "doman failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins acronyms || die "doins failed"
+ prepgamesdirs
}