summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-08 06:59:19 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-08 06:59:19 +0000
commit3b9072b80f31183e810df13cf7bd2cc386cba8b3 (patch)
tree469dbd25a7b7deb3e1a4f48a0991f1f558aec82b /games-kids/tuxmathscrabble
parentwont work w/out ipv6 #32860 (diff)
downloadhistorical-3b9072b80f31183e810df13cf7bd2cc386cba8b3.tar.gz
historical-3b9072b80f31183e810df13cf7bd2cc386cba8b3.tar.bz2
historical-3b9072b80f31183e810df13cf7bd2cc386cba8b3.zip
ver bump #32873
Diffstat (limited to 'games-kids/tuxmathscrabble')
-rw-r--r--games-kids/tuxmathscrabble/ChangeLog7
-rw-r--r--games-kids/tuxmathscrabble/files/2.2-gentoo-paths.patch73
-rw-r--r--games-kids/tuxmathscrabble/files/2.4a-fix-setup.patch28
-rw-r--r--games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.21
-rw-r--r--games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.4a1
-rw-r--r--games-kids/tuxmathscrabble/files/tuxmathscrabble3
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild42
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild38
8 files changed, 73 insertions, 120 deletions
diff --git a/games-kids/tuxmathscrabble/ChangeLog b/games-kids/tuxmathscrabble/ChangeLog
index 5b5e5b43473b..351786722064 100644
--- a/games-kids/tuxmathscrabble/ChangeLog
+++ b/games-kids/tuxmathscrabble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/tuxmathscrabble
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.2 2003/09/10 15:57:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.3 2003/11/08 06:59:19 vapier Exp $
+
+*tuxmathscrabble-2.4a (08 Nov 2003)
+
+ 08 Nov 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #32873.
*tuxmathscrabble-2.2 (03 Aug 2003)
diff --git a/games-kids/tuxmathscrabble/files/2.2-gentoo-paths.patch b/games-kids/tuxmathscrabble/files/2.2-gentoo-paths.patch
deleted file mode 100644
index e0dd4c7aa777..000000000000
--- a/games-kids/tuxmathscrabble/files/2.2-gentoo-paths.patch
+++ /dev/null
@@ -1,73 +0,0 @@
---- tuxmathscrabble.py.orig 2003-03-05 15:10:31.000000000 -0500
-+++ tuxmathscrabble.py 2003-03-05 15:11:22.000000000 -0500
-@@ -58,7 +58,7 @@
- pygame.display.set_caption('www.asymptopia.com')
- pygame.mouse.set_visible(1)
-
-- self.pyfont=pygame.font.Font('font/freesansbold.ttf',16)
-+ self.pyfont=pygame.font.Font('GENTOO_DATADIR/font/freesansbold.ttf',16)
- #print 'using freesansbold.ttf: ',self.pyfont
-
- self.LEVEL=level
-@@ -70,11 +70,11 @@
- win_sound=load_sound('sparcle.wav')
- lose_sound=load_sound('foghorn2.wav')
-
-- reset_button=Button('images/reset.jpeg')
-+ reset_button=Button('GENTOO_DATADIR/images/reset.jpeg')
- reset_button.rect.center=(820,430)
-- skip_button=Button('images/skip.jpeg')
-+ skip_button=Button('GENTOO_DATADIR/images/skip.jpeg')
- skip_button.rect.center=(820,500)
-- ready_button=Button('images/ready.jpeg')
-+ ready_button=Button('GENTOO_DATADIR/images/ready.jpeg')
- ready_button.rect.center=(820,570)
- buttongroup=pygame.sprite.Group([ready_button,skip_button,reset_button])
- buttons=pygame.sprite.RenderPlain(buttongroup)
-@@ -84,13 +84,13 @@
- background.fill((0, 150, 100))#green
-
- #Specific Test beyond this point:
-- board=Board(M,N,W/2,H/2,None,'images/spot.jpeg')
-+ board=Board(M,N,W/2,H/2,None,'GENTOO_DATADIR/images/spot.jpeg')
- boardspots=pygame.sprite.RenderPlain(board.get_spots())
-
-- tray=Board(1,10,W/2,H-40,None,'images/spot.jpeg')
-+ tray=Board(1,10,W/2,H-40,None,'GENTOO_DATADIR/images/spot.jpeg')
- trayspots=pygame.sprite.RenderPlain(tray.get_spots())
-
-- submission=Board(M,N,W/2,H/2,None,'images/spot.jpeg')
-+ submission=Board(M,N,W/2,H/2,None,'GENTOO_DATADIR/images/spot.jpeg')
- submissionspots=pygame.sprite.RenderPlain()
-
- #drag-n-drop object
-@@ -120,7 +120,7 @@
-
-
-
-- tuxtray=Board(1,10,W/2,80,None,'images/spot.jpeg')
-+ tuxtray=Board(1,10,W/2,80,None,'GENTOO_DATADIR/images/spot.jpeg')
- tuxtrayspots=pygame.sprite.RenderPlain(tuxtray.get_spots())
- self.tuxtrayspots=tuxtrayspots
- self.tuxtray=tuxtray
-@@ -134,7 +134,7 @@
- if spot.getMN()[1]<6:
- int_val=int(11*random())
- str_val=`int_val`
-- fname='images/'+imgnames[int_val]+'.jpeg'
-+ fname='GENTOO_DATADIR/images/'+imgnames[int_val]+'.jpeg'
- elif spot.getMN()[1]<10-1:
- opnames=['plus','minus','mult']
- idx=int(2*random())
-@@ -143,9 +143,9 @@
- elif opnames[idx]=='minus':str_val='-'
- elif opnames[idx]=='mult':str_val='*'
- else:pass
-- fname='images/'+opnames[idx]+'.jpeg'
-+ fname='GENTOO_DATADIR/images/'+opnames[idx]+'.jpeg'
- else:
-- fname='images/equal.jpeg'
-+ fname='GENTOO_DATADIR/images/equal.jpeg'
- int_val=None
- str_val='='
- tile=Tile(fname,int_val,str_val)
diff --git a/games-kids/tuxmathscrabble/files/2.4a-fix-setup.patch b/games-kids/tuxmathscrabble/files/2.4a-fix-setup.patch
new file mode 100644
index 000000000000..e2c0053aad78
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/2.4a-fix-setup.patch
@@ -0,0 +1,28 @@
+--- setup.py.orig 2003-11-08 01:35:57.007471792 -0500
++++ setup.py 2003-11-08 01:36:34.228813288 -0500
+@@ -61,8 +61,6 @@
+ sys.argv.append('install')
+
+ if sys.platform != 'win32':
+- try:os.system('rm -rf /usr/local/lib/python2.2/site-packages/asymptopia')
+- except Exception,e:pass
+ os.system('rm -rf build')
+ os.system('rm -f asymptopia/*.pyc')
+
+@@ -65,7 +65,6 @@
+ os.system('rm -f asymptopia/*.pyc')
+
+
+-sys.argv.append('install')
+
+ #make sure there is a Setup file
+ if not os.path.isfile('Setup'):
+@@ -154,8 +152,5 @@
+ PACKAGEDATA.update(METADATA)
+ apply(setup, [], PACKAGEDATA)
+
+-if sys.platform != 'win32':
+- os.system('cp tuxmathscrabble.py /usr/local/bin/tuxmathscrabble')
+- os.system('chmod +x /usr/local/bin/tuxmathscrabble')
+
+
diff --git a/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.2 b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.2
deleted file mode 100644
index 84e38ed07f66..000000000000
--- a/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 6c54076cc202b1998a92859e960fe823 TuxMathScrabble.tgz 232064
diff --git a/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.4a b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.4a
new file mode 100644
index 000000000000..bc8ccc9e4d50
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.4a
@@ -0,0 +1 @@
+MD5 5aba2f7dcb1a250913166dfc420cc96e TuxMathScrabble_v2_4a.tgz 654284
diff --git a/games-kids/tuxmathscrabble/files/tuxmathscrabble b/games-kids/tuxmathscrabble/files/tuxmathscrabble
deleted file mode 100644
index ca91cd2b78ae..000000000000
--- a/games-kids/tuxmathscrabble/files/tuxmathscrabble
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd GENTOO_LIBDIR
-exec /usr/bin/env python ./tuxmathscrabble.py "$@"
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild
deleted file mode 100644
index f6a6ac886256..000000000000
--- a/games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild,v 1.1 2003/09/10 04:51:18 vapier Exp $
-
-inherit eutils games
-
-DESCRIPTION="math-version of the popular board game for children 4-10"
-HOMEPAGE="http://sourceforge.net/projects/tuxmathscrabble/"
-SRC_URI="mirror://sourceforge/tuxmathscrabble/TuxMathScrabble.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-
-DEPEND=""
-RDEPEND="dev-python/pygame
- dev-lang/python"
-
-S=${WORKDIR}/TuxMathScrabble
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-gentoo-paths.patch
- sed -i "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}/:" tuxmathscrabble.py
-}
-
-src_install() {
- dogamesbin ${FILESDIR}/tuxmathscrabble
- dosed "s:GENTOO_LIBDIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/tuxmathscrabble
- exeinto ${GAMES_LIBDIR}/${PN}
- doexe tuxmathscrabble.py
- cp -r asymptopia ${D}/${GAMES_LIBDIR}/${PN}/
-
- insinto ${GAMES_DATADIR}/${PN}/font
- doins font/*
- insinto ${GAMES_DATADIR}/${PN}/images
- doins images/*
-
- dodoc AUTHOR README
- prepgamesdirs
-}
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild
new file mode 100644
index 000000000000..1b52e9c681ee
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-2.4a.ebuild,v 1.1 2003/11/08 06:59:19 vapier Exp $
+
+inherit games distutils
+
+MY_P=TuxMathScrabble_v${PV//./_}
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="mirror://sourceforge/tuxmathscrabble/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ dev-python/pygame
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-fix-setup.patch
+ sed -i 's:/usr/local/bin/python:/usr/bin/python:' tuxmathscrabble.py
+}
+
+src_install() {
+ DOCS="AUTHOR CHANGES VERSION"
+ distutils_src_install
+ newgamesbin tuxmathscrabble.py tuxmathscrabble
+ prepgamesdirs
+}