summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 04:51:18 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 04:51:18 +0000
commit0dc29cff4e12fae2eb0bb948a091d22786338b91 (patch)
treeda3c11db9af34b511ce87e070777fe85e97ed2b9 /games-kids/tuxmathscrabble
parentrepoman: fix leading whitespace (diff)
downloadhistorical-0dc29cff4e12fae2eb0bb948a091d22786338b91.tar.gz
historical-0dc29cff4e12fae2eb0bb948a091d22786338b91.tar.bz2
historical-0dc29cff4e12fae2eb0bb948a091d22786338b91.zip
hello kiddies
Diffstat (limited to 'games-kids/tuxmathscrabble')
-rw-r--r--games-kids/tuxmathscrabble/ChangeLog13
-rw-r--r--games-kids/tuxmathscrabble/Manifest5
-rw-r--r--games-kids/tuxmathscrabble/files/2.2-gentoo-paths.patch73
-rw-r--r--games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.21
-rw-r--r--games-kids/tuxmathscrabble/files/tuxmathscrabble3
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild42
6 files changed, 137 insertions, 0 deletions
diff --git a/games-kids/tuxmathscrabble/ChangeLog b/games-kids/tuxmathscrabble/ChangeLog
new file mode 100644
index 000000000000..8943b1e77353
--- /dev/null
+++ b/games-kids/tuxmathscrabble/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-games/tuxmathscrabble
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/ChangeLog,v 1.1 2003/09/10 04:51:18 vapier Exp $
+
+*tuxmathscrabble-2.2 (03 Aug 2003)
+
+ 03 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
+
+*tuxmathscrabble-0.1.0 (05 Mar 2003)
+
+ 05 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me for #15040.
diff --git a/games-kids/tuxmathscrabble/Manifest b/games-kids/tuxmathscrabble/Manifest
new file mode 100644
index 000000000000..7ee6d15d1333
--- /dev/null
+++ b/games-kids/tuxmathscrabble/Manifest
@@ -0,0 +1,5 @@
+MD5 6dfec3d3795fdac1f2426cfd8560321b files/2.2-gentoo-paths.patch 2705
+MD5 26574948a91d425e65db57c5fba56362 files/digest-tuxmathscrabble-2.2 64
+MD5 409886a536ec545e6fa36ae2301a8bde files/tuxmathscrabble 78
+MD5 21b511f92bd4422686d8a366225ba3a5 ChangeLog 481
+MD5 adb93e8eae8c160f2426f0b7111682fd tuxmathscrabble-2.2.ebuild 1133
diff --git a/games-kids/tuxmathscrabble/files/2.2-gentoo-paths.patch b/games-kids/tuxmathscrabble/files/2.2-gentoo-paths.patch
new file mode 100644
index 000000000000..e0dd4c7aa777
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/2.2-gentoo-paths.patch
@@ -0,0 +1,73 @@
+--- tuxmathscrabble.py.orig 2003-03-05 15:10:31.000000000 -0500
++++ tuxmathscrabble.py 2003-03-05 15:11:22.000000000 -0500
+@@ -58,7 +58,7 @@
+ pygame.display.set_caption('www.asymptopia.com')
+ pygame.mouse.set_visible(1)
+
+- self.pyfont=pygame.font.Font('font/freesansbold.ttf',16)
++ self.pyfont=pygame.font.Font('GENTOO_DATADIR/font/freesansbold.ttf',16)
+ #print 'using freesansbold.ttf: ',self.pyfont
+
+ self.LEVEL=level
+@@ -70,11 +70,11 @@
+ win_sound=load_sound('sparcle.wav')
+ lose_sound=load_sound('foghorn2.wav')
+
+- reset_button=Button('images/reset.jpeg')
++ reset_button=Button('GENTOO_DATADIR/images/reset.jpeg')
+ reset_button.rect.center=(820,430)
+- skip_button=Button('images/skip.jpeg')
++ skip_button=Button('GENTOO_DATADIR/images/skip.jpeg')
+ skip_button.rect.center=(820,500)
+- ready_button=Button('images/ready.jpeg')
++ ready_button=Button('GENTOO_DATADIR/images/ready.jpeg')
+ ready_button.rect.center=(820,570)
+ buttongroup=pygame.sprite.Group([ready_button,skip_button,reset_button])
+ buttons=pygame.sprite.RenderPlain(buttongroup)
+@@ -84,13 +84,13 @@
+ background.fill((0, 150, 100))#green
+
+ #Specific Test beyond this point:
+- board=Board(M,N,W/2,H/2,None,'images/spot.jpeg')
++ board=Board(M,N,W/2,H/2,None,'GENTOO_DATADIR/images/spot.jpeg')
+ boardspots=pygame.sprite.RenderPlain(board.get_spots())
+
+- tray=Board(1,10,W/2,H-40,None,'images/spot.jpeg')
++ tray=Board(1,10,W/2,H-40,None,'GENTOO_DATADIR/images/spot.jpeg')
+ trayspots=pygame.sprite.RenderPlain(tray.get_spots())
+
+- submission=Board(M,N,W/2,H/2,None,'images/spot.jpeg')
++ submission=Board(M,N,W/2,H/2,None,'GENTOO_DATADIR/images/spot.jpeg')
+ submissionspots=pygame.sprite.RenderPlain()
+
+ #drag-n-drop object
+@@ -120,7 +120,7 @@
+
+
+
+- tuxtray=Board(1,10,W/2,80,None,'images/spot.jpeg')
++ tuxtray=Board(1,10,W/2,80,None,'GENTOO_DATADIR/images/spot.jpeg')
+ tuxtrayspots=pygame.sprite.RenderPlain(tuxtray.get_spots())
+ self.tuxtrayspots=tuxtrayspots
+ self.tuxtray=tuxtray
+@@ -134,7 +134,7 @@
+ if spot.getMN()[1]<6:
+ int_val=int(11*random())
+ str_val=`int_val`
+- fname='images/'+imgnames[int_val]+'.jpeg'
++ fname='GENTOO_DATADIR/images/'+imgnames[int_val]+'.jpeg'
+ elif spot.getMN()[1]<10-1:
+ opnames=['plus','minus','mult']
+ idx=int(2*random())
+@@ -143,9 +143,9 @@
+ elif opnames[idx]=='minus':str_val='-'
+ elif opnames[idx]=='mult':str_val='*'
+ else:pass
+- fname='images/'+opnames[idx]+'.jpeg'
++ fname='GENTOO_DATADIR/images/'+opnames[idx]+'.jpeg'
+ else:
+- fname='images/equal.jpeg'
++ fname='GENTOO_DATADIR/images/equal.jpeg'
+ int_val=None
+ str_val='='
+ tile=Tile(fname,int_val,str_val)
diff --git a/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.2 b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.2
new file mode 100644
index 000000000000..84e38ed07f66
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/digest-tuxmathscrabble-2.2
@@ -0,0 +1 @@
+MD5 6c54076cc202b1998a92859e960fe823 TuxMathScrabble.tgz 232064
diff --git a/games-kids/tuxmathscrabble/files/tuxmathscrabble b/games-kids/tuxmathscrabble/files/tuxmathscrabble
new file mode 100644
index 000000000000..ca91cd2b78ae
--- /dev/null
+++ b/games-kids/tuxmathscrabble/files/tuxmathscrabble
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_LIBDIR
+exec /usr/bin/env python ./tuxmathscrabble.py "$@"
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild
new file mode 100644
index 000000000000..f6a6ac886256
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmathscrabble/tuxmathscrabble-2.2.ebuild,v 1.1 2003/09/10 04:51:18 vapier Exp $
+
+inherit eutils games
+
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://sourceforge.net/projects/tuxmathscrabble/"
+SRC_URI="mirror://sourceforge/tuxmathscrabble/TuxMathScrabble.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=""
+RDEPEND="dev-python/pygame
+ dev-lang/python"
+
+S=${WORKDIR}/TuxMathScrabble
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gentoo-paths.patch
+ sed -i "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}/:" tuxmathscrabble.py
+}
+
+src_install() {
+ dogamesbin ${FILESDIR}/tuxmathscrabble
+ dosed "s:GENTOO_LIBDIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/tuxmathscrabble
+ exeinto ${GAMES_LIBDIR}/${PN}
+ doexe tuxmathscrabble.py
+ cp -r asymptopia ${D}/${GAMES_LIBDIR}/${PN}/
+
+ insinto ${GAMES_DATADIR}/${PN}/font
+ doins font/*
+ insinto ${GAMES_DATADIR}/${PN}/images
+ doins images/*
+
+ dodoc AUTHOR README
+ prepgamesdirs
+}