summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-21 06:01:20 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-21 06:01:20 +0000
commit1a444890f12b4ca4bf6d04e5318e1aa635c7afb0 (patch)
tree77dcc6f5a625577704d35d92997d502b74e3116c /games-kids/cubetest/cubetest-0.9.4.ebuild
parent(#131361) Filter -Bdirect LDFLAGS setting. (diff)
downloadhistorical-1a444890f12b4ca4bf6d04e5318e1aa635c7afb0.tar.gz
historical-1a444890f12b4ca4bf6d04e5318e1aa635c7afb0.tar.bz2
historical-1a444890f12b4ca4bf6d04e5318e1aa635c7afb0.zip
Version bump #115691 by maquiz.
Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'games-kids/cubetest/cubetest-0.9.4.ebuild')
-rw-r--r--games-kids/cubetest/cubetest-0.9.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-kids/cubetest/cubetest-0.9.4.ebuild b/games-kids/cubetest/cubetest-0.9.4.ebuild
new file mode 100644
index 000000000000..96b83d5a9ed9
--- /dev/null
+++ b/games-kids/cubetest/cubetest-0.9.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/cubetest/cubetest-0.9.4.ebuild,v 1.1 2006/06/21 06:01:20 vapier Exp $
+
+inherit qt4 eutils games
+
+DESCRIPTION="A program to train your spatial insight"
+HOMEPAGE="http://www.vandenoever.info/software/cubetest/"
+SRC_URI="http://www.vandenoever.info/software/cubetest/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 4)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ for i in $(find src/ -iname *_moc.cpp) ; do
+ moc ${i/_moc.cpp/.h} -o $i || die
+ done
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+}