summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Charles Campbell <warpzero@gentoo.org>2004-12-01 06:26:27 +0000
committerJoshua Charles Campbell <warpzero@gentoo.org>2004-12-01 06:26:27 +0000
commitadf714d0ac6858064aa1da4778938ff4ddd984cf (patch)
tree63eea5115f6364b2f76b9f2b52e0a988b86d37bc /games-fps
parentadd missing dep (diff)
downloadhistorical-adf714d0ac6858064aa1da4778938ff4ddd984cf.tar.gz
historical-adf714d0ac6858064aa1da4778938ff4ddd984cf.tar.bz2
historical-adf714d0ac6858064aa1da4778938ff4ddd984cf.zip
intial inport for vendetta-online-bin
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/vendetta-online-bin/ChangeLog10
-rw-r--r--games-fps/vendetta-online-bin/Manifest4
-rw-r--r--games-fps/vendetta-online-bin/files/digest-vendetta-online-bin-11
-rw-r--r--games-fps/vendetta-online-bin/metadata.xml5
-rw-r--r--games-fps/vendetta-online-bin/vendetta-online-bin-1.ebuild44
5 files changed, 64 insertions, 0 deletions
diff --git a/games-fps/vendetta-online-bin/ChangeLog b/games-fps/vendetta-online-bin/ChangeLog
new file mode 100644
index 000000000000..e87bb3e4a87e
--- /dev/null
+++ b/games-fps/vendetta-online-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/vendetta-online-bin
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/vendetta-online-bin/ChangeLog,v 1.1 2004/12/01 06:26:27 warpzero Exp $
+
+*vendetta-online-bin-1 (30 Nov 2004)
+
+ 30 Nov 2004; Joshua Charles Campbell <warpzero@gentoo.org> vendetta-online-bin1.ebuild:
+ initial commit, ebuild submitted by yoosty69@netzero.net and
+ Roguelazer@gmail.com
+
diff --git a/games-fps/vendetta-online-bin/Manifest b/games-fps/vendetta-online-bin/Manifest
new file mode 100644
index 000000000000..17e9d28554c9
--- /dev/null
+++ b/games-fps/vendetta-online-bin/Manifest
@@ -0,0 +1,4 @@
+MD5 538daba59eb39a5a55526b77ce0b7ceb vendetta-online-bin-1.ebuild 1173
+MD5 168ee0296a6dbf059bd81dbbc6570f06 ChangeLog 449
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 b3144657c0fb9cb7a584260cd6538df6 files/digest-vendetta-online-bin-1 75
diff --git a/games-fps/vendetta-online-bin/files/digest-vendetta-online-bin-1 b/games-fps/vendetta-online-bin/files/digest-vendetta-online-bin-1
new file mode 100644
index 000000000000..92804f667de4
--- /dev/null
+++ b/games-fps/vendetta-online-bin/files/digest-vendetta-online-bin-1
@@ -0,0 +1 @@
+MD5 b59ff3cc4d6b87e9202b529a1737572d vendetta-linux-installer.sh 113700756
diff --git a/games-fps/vendetta-online-bin/metadata.xml b/games-fps/vendetta-online-bin/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/vendetta-online-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/vendetta-online-bin/vendetta-online-bin-1.ebuild b/games-fps/vendetta-online-bin/vendetta-online-bin-1.ebuild
new file mode 100644
index 000000000000..e54525381c5b
--- /dev/null
+++ b/games-fps/vendetta-online-bin/vendetta-online-bin-1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/vendetta-online-bin/vendetta-online-bin-1.ebuild,v 1.1 2004/12/01 06:26:27 warpzero Exp $
+
+inherit games eutils
+
+DESCRIPTION="Space-based MMORPG with amazing graphics"
+HOMEPAGE="http://www.vendetta-online.com/"
+SRC_URI="vendetta-linux-installer.sh"
+S=${WORKDIR}
+
+RESTRICT="nomirror fetch"
+
+LICENSE="guild"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE="amd64"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="virtual/x11
+ virtual/opengl
+ =x11-libs/gtk+-1.2*
+ amd64? ( =app-emulation/emul-linux-x86-gtklibs-1.2* )"
+
+pkg_nofetch() {
+ einfo "You need to download ${A} from Guild Software by:"
+ einfo "1. Going to http://www.vendetta-online.com/ and creating your login"
+ einfo "2. Obtain ${A} from your CD"
+ einfo " OR"
+ einfo "2. Login to VO's website on the top-left under \"Web\","
+ einfo " and then downloading it from the \"Download\" link"
+ einfo " under \"Game\" on the left pane."
+ einfo "3. Put ${A} in ${DISTDIR}"
+ einfo "4. emerge vendetta-online-bin"
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ dogamesbin vendetta
+ prepgamesdirs
+}