summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
commitad69522f5e6b57d5350a46ebda16dbe091d0e4b6 (patch)
tree1580e46b57d69a004ab7bafb3f19590605890684 /games-fps/unreal-tournament-strikeforce
parentNew version 'n cleanup (diff)
downloadhistorical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.tar.gz
historical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.tar.bz2
historical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.zip
games-fps uNF uNF uNF
Diffstat (limited to 'games-fps/unreal-tournament-strikeforce')
-rw-r--r--games-fps/unreal-tournament-strikeforce/ChangeLog11
-rw-r--r--games-fps/unreal-tournament-strikeforce/Manifest3
-rw-r--r--games-fps/unreal-tournament-strikeforce/files/digest-unreal-tournament-strikeforce-1.753
-rw-r--r--games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild36
4 files changed, 53 insertions, 0 deletions
diff --git a/games-fps/unreal-tournament-strikeforce/ChangeLog b/games-fps/unreal-tournament-strikeforce/ChangeLog
new file mode 100644
index 000000000000..788654f22d52
--- /dev/null
+++ b/games-fps/unreal-tournament-strikeforce/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-games/strikeforce
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-strikeforce/ChangeLog,v 1.1 2003/09/09 18:10:15 vapier Exp $
+
+ 18 Jun 2003; Patrick Kursawe <phosphan@gentoo.org> strikeforce-1.75.ebuild:
+ Corrected download location for SF175.zip, bug #13269
+
+*strikeforce-1.75 (23 Oct 2002)
+
+ 23 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-fps/unreal-tournament-strikeforce/Manifest b/games-fps/unreal-tournament-strikeforce/Manifest
new file mode 100644
index 000000000000..9b65ecb5ebd0
--- /dev/null
+++ b/games-fps/unreal-tournament-strikeforce/Manifest
@@ -0,0 +1,3 @@
+MD5 ee428f0ea13ccf661f15b2c5456e3d5f files/digest-strikeforce-1.75 187
+MD5 63edbbe1533b5b0b4ca8f1ec1b784793 strikeforce-1.75.ebuild 1075
+MD5 7cb1b7eac2afb8e8dc44af086596e6d2 ChangeLog 488
diff --git a/games-fps/unreal-tournament-strikeforce/files/digest-unreal-tournament-strikeforce-1.75 b/games-fps/unreal-tournament-strikeforce/files/digest-unreal-tournament-strikeforce-1.75
new file mode 100644
index 000000000000..51b89d1449a1
--- /dev/null
+++ b/games-fps/unreal-tournament-strikeforce/files/digest-unreal-tournament-strikeforce-1.75
@@ -0,0 +1,3 @@
+MD5 e4aae05175f5e039a265d2068f5a7ee3 SF175.zip 115436985
+MD5 2c376557565baea9342b3e848a2cd430 sf175_mappack1.zip 35767354
+MD5 622c20248cc678791f790923532af50f sf175_mappack2.zip 59315718
diff --git a/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild b/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild
new file mode 100644
index 000000000000..ae6bac51561b
--- /dev/null
+++ b/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.75.ebuild,v 1.1 2003/09/09 18:10:15 vapier Exp $
+
+inherit games
+
+MY_PV=${PV/./}
+DESCRIPTION="A UT addon where you fight terrorists as part of an elite strikeforce"
+HOMEPAGE="http://www.strikeforcecenter.com/"
+SRC_URI="http://www.zvdk.nl/downloads/server/SF${MY_PV}.zip
+ http://www.zvdk.nl/downloads/client/sf${MY_PV}_mappack1.zip
+ http://www.zvdk.nl/downloads/client/sf${MY_PV}_mappack2.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="|| ( app-games/unreal-tournament app-games/unreal-tournament-goty )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # we gotta do this cause there is a duplicate file across these zip's ...
+ unpack SF${MY_PV}.zip
+ unpack sf${MY_PV}_mappack1.zip
+ rm -rf SF_Sounds/urbansnds.uax
+ unpack sf${MY_PV}_mappack2.zip
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/unreal-tournament
+ dodir ${dir}/Help
+ mv *.txt ${D}/${dir}/Help/
+ mv * ${D}/${dir}/
+ prepgamesdirs
+}