summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-02 16:19:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-02 16:19:23 +0000
commit60b08428c1064bc0fe89dc5e4f8ff7b05293c02e (patch)
tree2432ed3793abed9618a41254566f1119acc9da88 /games-fps/unreal-tournament-goty
parentthis is 2.0.6d which is a security release. see bug 43474 (diff)
downloadhistorical-60b08428c1064bc0fe89dc5e4f8ff7b05293c02e.tar.gz
historical-60b08428c1064bc0fe89dc5e4f8ff7b05293c02e.tar.bz2
historical-60b08428c1064bc0fe89dc5e4f8ff7b05293c02e.zip
allow CDROM_ROOT to have spaces #43483
Diffstat (limited to 'games-fps/unreal-tournament-goty')
-rw-r--r--games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild28
-rw-r--r--games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild28
2 files changed, 28 insertions, 28 deletions
diff --git a/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild b/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
index fe325dd67e68..ba9e2b187df4 100644
--- a/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
+++ b/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v 1.3 2004/02/08 21:28:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v 1.4 2004/03/02 16:19:23 vapier Exp $
inherit games eutils
@@ -60,20 +60,20 @@ src_install() {
###########
### CD1 ###
# Help, Logs, Music, Sounds, Textures, Web
- cp -rf ${CDROM_ROOT}/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
+ cp -rf "${CDROM_ROOT}"/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
dodir ${dir}/Sounds
if [ `use nls` ] ; then
- cp -rf ${CDROM_ROOT}/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf "${CDROM_ROOT}"/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
else
- cp -rf ${CDROM_ROOT}/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf "${CDROM_ROOT}"/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
fi
# System
dodir ${dir}/System
if [ `use nls` ] ; then
- cp ${CDROM_ROOT}/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp "${CDROM_ROOT}"/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
else
- cp ${CDROM_ROOT}/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp "${CDROM_ROOT}"/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
fi
# now we uncompress the maps
@@ -82,8 +82,8 @@ src_install() {
cd ${Ddir}
export HOME=${T}
export UT_DATA_PATH=${Ddir}/System
- for f in `find ${CDROM_ROOT}/Maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${CDROM_ROOT}/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
+ for f in `find "${CDROM_ROOT}"/Maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress "${CDROM_ROOT}"/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD1 ${f}"
done
### CD1 ###
@@ -95,17 +95,17 @@ src_install() {
###########
### CD2 ###
# Help, Sounds
- cp -rf ${CDROM_ROOT}/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
+ cp -rf "${CDROM_ROOT}"/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
# S3TC Textures
if [ `use S3TC` ] ; then
- cp -rf ${CDROM_ROOT}/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
+ cp -rf "${CDROM_ROOT}"/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
else
- cp -rf ${CDROM_ROOT}/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
+ cp -rf "${CDROM_ROOT}"/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
fi
# System
- cp -rf ${CDROM_ROOT}/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
+ cp -rf "${CDROM_ROOT}"/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
# now we uncompress the maps
einfo "Uncompressing CD2 Maps ... this may take some time"
@@ -113,8 +113,8 @@ src_install() {
cd ${Ddir}
export HOME=${T}
export UT_DATA_PATH=${Ddir}/System
- for f in `find ${CDROM_ROOT}/maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${CDROM_ROOT}/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
+ for f in `find "${CDROM_ROOT}"/maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress "${CDROM_ROOT}"/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD2 ${f}"
done
### CD2 ###
diff --git a/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild b/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
index 61fe77949cc7..816d008b02fd 100644
--- a/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
+++ b/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v 1.3 2004/02/08 21:28:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v 1.4 2004/03/02 16:19:23 vapier Exp $
inherit games eutils
@@ -62,20 +62,20 @@ src_install() {
###########
### CD1 ###
# Help, Logs, Music, Sounds, Textures, Web
- cp -rf ${CDROM_ROOT}/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
+ cp -rf "${CDROM_ROOT}"/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
dodir ${dir}/Sounds
if [ `use nls` ] ; then
- cp -rf ${CDROM_ROOT}/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf "${CDROM_ROOT}"/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
else
- cp -rf ${CDROM_ROOT}/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf "${CDROM_ROOT}"/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
fi
# System
dodir ${dir}/System
if [ `use nls` ] ; then
- cp ${CDROM_ROOT}/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp "${CDROM_ROOT}"/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
else
- cp ${CDROM_ROOT}/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp "${CDROM_ROOT}"/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
fi
# now we uncompress the maps
@@ -84,8 +84,8 @@ src_install() {
cd ${Ddir}
export HOME=${T}
export UT_DATA_PATH=${Ddir}/System
- for f in `find ${CDROM_ROOT}/Maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${CDROM_ROOT}/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
+ for f in `find "${CDROM_ROOT}"/Maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress "${CDROM_ROOT}"/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD1 ${f}"
done
### CD1 ###
@@ -97,17 +97,17 @@ src_install() {
###########
### CD2 ###
# Help, Sounds
- cp -rf ${CDROM_ROOT}/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
+ cp -rf "${CDROM_ROOT}"/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
# S3TC Textures
if [ `use S3TC` ] ; then
- cp -rf ${CDROM_ROOT}/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
+ cp -rf "${CDROM_ROOT}"/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
else
- cp -rf ${CDROM_ROOT}/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
+ cp -rf "${CDROM_ROOT}"/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
fi
# System
- cp -rf ${CDROM_ROOT}/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
+ cp -rf "${CDROM_ROOT}"/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
# now we uncompress the maps
einfo "Uncompressing CD2 Maps ... this may take some time"
@@ -115,8 +115,8 @@ src_install() {
cd ${Ddir}
export HOME=${T}
export UT_DATA_PATH=${Ddir}/System
- for f in `find ${CDROM_ROOT}/maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${CDROM_ROOT}/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
+ for f in `find "${CDROM_ROOT}"/maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress "${CDROM_ROOT}"/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD2 ${f}"
done
### CD2 ###