summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-08-31 22:17:26 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-08-31 22:17:26 +0000
commitf152ad6c19704b77c0d844305e340985988bef37 (patch)
treeab1702aa7f993f118be7ff4119c5de41cea5a2f9 /games-fps/doomsday
parentVersion bump #56989 (diff)
downloadhistorical-f152ad6c19704b77c0d844305e340985988bef37.tar.gz
historical-f152ad6c19704b77c0d844305e340985988bef37.tar.bz2
historical-f152ad6c19704b77c0d844305e340985988bef37.zip
Version bumped to 1.8.1 and adding 1.8.1-ambient-light.patch submitted by dilipv@hotmail.com to bug #61072.
Diffstat (limited to 'games-fps/doomsday')
-rw-r--r--games-fps/doomsday/ChangeLog8
-rw-r--r--games-fps/doomsday/Manifest16
-rw-r--r--games-fps/doomsday/doomsday-1.8.1.ebuild46
-rw-r--r--games-fps/doomsday/files/digest-doomsday-1.8.11
4 files changed, 58 insertions, 13 deletions
diff --git a/games-fps/doomsday/ChangeLog b/games-fps/doomsday/ChangeLog
index 8bf16e739392..c92e746c7fe1 100644
--- a/games-fps/doomsday/ChangeLog
+++ b/games-fps/doomsday/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/doomsday
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/ChangeLog,v 1.1 2004/07/21 04:24:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/ChangeLog,v 1.2 2004/08/31 22:17:26 wolf31o2 Exp $
+
+*doomsday-1.8.1 (31 Aug 2004)
+
+ 31 Aug 2004; Chris Gianelloni <wolf31o2@gentoo.org> +doomsday-1.8.1.ebuild:
+ Version bumped to 1.8.1 and adding 1.8.1-ambient-light.patch submitted by
+ dilipv@hotmail.com to bug #61072.
*doomsday-1.8.0 (21 Jul 2004)
diff --git a/games-fps/doomsday/Manifest b/games-fps/doomsday/Manifest
index a79fca199650..66de7d92c0c8 100644
--- a/games-fps/doomsday/Manifest
+++ b/games-fps/doomsday/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 dc566ec8d6cc1be09aa65fef800ba258 doomsday-1.8.1.ebuild 1185
MD5 8746da74b983aa22bfa561f899818e12 doomsday-1.8.0.ebuild 1135
+MD5 d65d537f7fea73b2df2ca3a4496378ca ChangeLog 593
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 f685444ddf8a83c1f7d779eb05e45973 ChangeLog 369
+MD5 c9f45fe4b0c154013fe56c8915ebd3f1 files/digest-doomsday-1.8.0 63
+MD5 61f292434360c86e2522774cfeb44886 files/digest-doomsday-1.8.1 63
MD5 5f91dc6393ff5aba59c015a5ab9ccbd0 files/1.8.0-filename-case.patch 502
MD5 5fa792096b783fb6b3cd3bd45c2f709c files/wrapper 136
-MD5 c9f45fe4b0c154013fe56c8915ebd3f1 files/digest-doomsday-1.8.0 63
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
-
-iD8DBQFA/fASHTu7gpaalycRAmd9AKC5O9pR67eDUmhn03D5A3uEcwA8QwCgjalS
-5J/I/PK3LcE+urs0Kp2LmSg=
-=soQA
------END PGP SIGNATURE-----
diff --git a/games-fps/doomsday/doomsday-1.8.1.ebuild b/games-fps/doomsday/doomsday-1.8.1.ebuild
new file mode 100644
index 000000000000..5df08aa08e79
--- /dev/null
+++ b/games-fps/doomsday/doomsday-1.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/doomsday-1.8.1.ebuild,v 1.1 2004/08/31 22:17:26 wolf31o2 Exp $
+
+inherit games eutils
+
+DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
+HOMEPAGE="http://www.doomsdayhq.com/"
+SRC_URI="mirror://sourceforge/deng/deng-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="openal"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ openal? ( media-libs/openal )"
+
+S=${WORKDIR}/deng-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# epatch ${FILESDIR}/${PV}-filename-case.patch
+ epatch ${FILESDIR}/${PV}-ambient-light.patch
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "egamesinstall failed"
+ rmdir ${D}/${GAMES_PREFIX}/include
+ mv ${D}/${GAMES_DATADIR}/{deng/Data/jDoom,doom-data}
+ dosym ${GAMES_DATADIR}/doom-data ${GAMES_DATADIR}/deng/Data/jDoom
+
+ local game
+ for game in jdoom jheretic jhexen ; do
+ newgamesbin ${FILESDIR}/wrapper ${game}
+ dosed "s:GAME:${game}:" ${GAMES_BINDIR}/${game}
+ done
+
+ dodoc Doc/*.txt Doc/*/*.txt README
+ prepgamesdirs
+}
diff --git a/games-fps/doomsday/files/digest-doomsday-1.8.1 b/games-fps/doomsday/files/digest-doomsday-1.8.1
new file mode 100644
index 000000000000..37367c61cb5f
--- /dev/null
+++ b/games-fps/doomsday/files/digest-doomsday-1.8.1
@@ -0,0 +1 @@
+MD5 972e34e6a44aa80090501bbae936a7c8 deng-1.8.1.tar.gz 3140581