summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-06 07:43:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-06 07:43:07 +0000
commitf137ac1c86af1dbc74c21707ceef9af734bf99d9 (patch)
treef35c9047f601529f34304aa429ab005c10ab8bd3 /games-emulation
parentkeyword amd64 and ppc (diff)
downloadhistorical-f137ac1c86af1dbc74c21707ceef9af734bf99d9.tar.gz
historical-f137ac1c86af1dbc74c21707ceef9af734bf99d9.tar.bz2
historical-f137ac1c86af1dbc74c21707ceef9af734bf99d9.zip
version bump (bug #51874)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest14
-rw-r--r--games-emulation/advancemame/advancemame-0.82.0.ebuild75
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.82.01
4 files changed, 91 insertions, 7 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 4edcc8c9b74c..63adf1cd0367 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.9 2004/04/28 14:45:36 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.10 2004/06/06 07:43:07 mr_bones_ Exp $
+
+*advancemame-0.82.0 (06 Jun 2004)
+
+ 06 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ advancemame-0.82.0.ebuild:
+ version bump (bug #51874)
*advancemame-0.81.0 (08 Apr 2004)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index 38ce5cb83343..599ff8764023 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,8 +1,10 @@
-MD5 c5dd3cee0f731cccc30e89067f0e0777 files/digest-advancemame-0.78.0 72
-MD5 ee6170be60235d6f49882f80dadd122d files/digest-advancemame-0.81.0 72
-MD5 d5d580fd228271ce09bb83027f21a14b files/digest-advancemame-0.77.2 72
-MD5 7a7d49581fa7b36d68657ed43215134b ChangeLog 2494
-MD5 9ad5b3665357db5e5bceb77f8631577f advancemame-0.78.0.ebuild 1527
-MD5 8401e2293fc040d71bd2a5c705fc1081 advancemame-0.81.0.ebuild 1792
+MD5 a92afbbf2f38a7233d2624420fe2fc0a ChangeLog 2647
MD5 8fdc3b80b152afdec14bd9018d024bc3 advancemame-0.77.2.ebuild 1527
+MD5 9ad5b3665357db5e5bceb77f8631577f advancemame-0.78.0.ebuild 1527
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
+MD5 8401e2293fc040d71bd2a5c705fc1081 advancemame-0.81.0.ebuild 1792
+MD5 874a5aea5b0ac9ae785165672cd5f11b advancemame-0.82.0.ebuild 1794
+MD5 d5d580fd228271ce09bb83027f21a14b files/digest-advancemame-0.77.2 72
+MD5 c5dd3cee0f731cccc30e89067f0e0777 files/digest-advancemame-0.78.0 72
+MD5 ee6170be60235d6f49882f80dadd122d files/digest-advancemame-0.81.0 72
+MD5 944467fa089d4a3c69a91dabc23bcd85 files/digest-advancemame-0.82.0 72
diff --git a/games-emulation/advancemame/advancemame-0.82.0.ebuild b/games-emulation/advancemame/advancemame-0.82.0.ebuild
new file mode 100644
index 000000000000..46be6bd8eaa2
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.82.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.82.0.ebuild,v 1.1 2004/06/06 07:43:07 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="debug static svga truetype fbcon alsa oss slang sdl"
+
+RDEPEND="virtual/glibc
+ app-arch/unzip
+ app-arch/zip
+ x86? ( >=dev-lang/nasm-0.98 )
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable debug) \
+ $(use_enable truetype freetype) \
+ $(use_enable static) \
+ $(use_enable x86 asm) \
+ $(use_enable svga svgalib) \
+ $(use_enable fbcon fb) \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable slang) \
+ $(use_enable sdl) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local m
+
+ dogamesbin adv* || die "dogamesbin failed"
+
+ keepdir "${GAMES_DATADIR}"/advance/{artwork,diff,image,rom,sample,snap}
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+
+ dodoc HISTORY README RELEASE
+ cd obj/doc
+ dodoc *.txt
+ dohtml *.html
+ for m in *.1 ; do
+ newman ${m} ${m/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.82.0 b/games-emulation/advancemame/files/digest-advancemame-0.82.0
new file mode 100644
index 000000000000..bfab3dbf61d1
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.82.0
@@ -0,0 +1 @@
+MD5 a80eccc57d29ce1645e491746be3e87a advancemame-0.82.0.tar.gz 11600749