summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-18 11:46:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-18 11:46:47 +0000
commit7628944c34dd0da9032d4a2c8be593a89a32bf6a (patch)
treeaac9d43ffae4b01af10c4cb533e938064115785f /games-emulation
parentDisable festival support (diff)
downloadhistorical-7628944c34dd0da9032d4a2c8be593a89a32bf6a.tar.gz
historical-7628944c34dd0da9032d4a2c8be593a89a32bf6a.tar.bz2
historical-7628944c34dd0da9032d4a2c8be593a89a32bf6a.zip
patch from Roman 'gryf' Dobosz via bug #57004 to fix rom name after rebuild
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/grustibus/ChangeLog6
-rw-r--r--games-emulation/grustibus/Manifest7
-rw-r--r--games-emulation/grustibus/files/0.43-filename.patch12
-rw-r--r--games-emulation/grustibus/grustibus-0.43-r4.ebuild3
4 files changed, 23 insertions, 5 deletions
diff --git a/games-emulation/grustibus/ChangeLog b/games-emulation/grustibus/ChangeLog
index ff4ed4d91659..5ea21315c293 100644
--- a/games-emulation/grustibus/ChangeLog
+++ b/games-emulation/grustibus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/grustibus
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/grustibus/ChangeLog,v 1.5 2004/06/24 22:28:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/grustibus/ChangeLog,v 1.6 2004/09/18 11:46:47 mr_bones_ Exp $
+
+ 18 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ grustibus-0.43-r4.ebuild:
+ patch from Roman 'gryf' Dobosz via bug #57004 to fix rom name after rebuild
22 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+files/0.43-crash.patch, grustibus-0.43-r4.ebuild:
diff --git a/games-emulation/grustibus/Manifest b/games-emulation/grustibus/Manifest
index 4f15db6d7554..fca4c8400ae5 100644
--- a/games-emulation/grustibus/Manifest
+++ b/games-emulation/grustibus/Manifest
@@ -1,5 +1,6 @@
-MD5 e70b6dbb757b56b72fa7c642a99dbb05 grustibus-0.43-r4.ebuild 866
-MD5 9423370f772c7b264405dfd612262b9e ChangeLog 1974
+MD5 bac8a2a3b479e3802ccc1561b94c09ff ChangeLog 2137
+MD5 d0b686bbfe9febfba345ba354b49782d grustibus-0.43-r4.ebuild 923
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 946795d8f2dee0a69b475525a126710a files/0.43-crash.patch 9810
MD5 dd4620294ac5183f481b4a0b563d3673 files/digest-grustibus-0.43-r4 66
+MD5 946795d8f2dee0a69b475525a126710a files/0.43-crash.patch 9810
+MD5 64e801eab37d31db3fd33a7781abdf4d files/0.43-filename.patch 466
diff --git a/games-emulation/grustibus/files/0.43-filename.patch b/games-emulation/grustibus/files/0.43-filename.patch
new file mode 100644
index 000000000000..3add555d2752
--- /dev/null
+++ b/games-emulation/grustibus/files/0.43-filename.patch
@@ -0,0 +1,12 @@
+diff -Nur grustibus-0.43/src/mameio.c grustibus-0.43p2/src/mameio.c
+--- grustibus-0.43/src/mameio.c 2001-05-28 02:09:06.000000000 +0200
++++ grustibus-0.43p2/src/mameio.c 2004-07-14 12:02:33.000000000 +0200
+@@ -168,7 +168,7 @@
+
+
+ if (p[0] == '\"')
+- *p = *p++;
++ *p++;
+ value = p;
+
+ i = 0;
diff --git a/games-emulation/grustibus/grustibus-0.43-r4.ebuild b/games-emulation/grustibus/grustibus-0.43-r4.ebuild
index 346bb7c9dcea..32dc63542feb 100644
--- a/games-emulation/grustibus/grustibus-0.43-r4.ebuild
+++ b/games-emulation/grustibus/grustibus-0.43-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/grustibus/grustibus-0.43-r4.ebuild,v 1.6 2004/06/24 22:28:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/grustibus/grustibus-0.43-r4.ebuild,v 1.7 2004/09/18 11:46:47 mr_bones_ Exp $
inherit eutils
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch "${FILESDIR}/${PV}-crash.patch"
+ epatch "${FILESDIR}/${PV}-filename.patch" # bug #57004
}
src_compile() {