summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 06:02:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 06:02:59 +0000
commitccd13cee68771e6366440a005f919ef4a48e7c7b (patch)
tree99d9062a726fb1d1c5805927ed3e6ab77de1048d /games-emulation/xmame
parentdont need glibc (diff)
downloadhistorical-ccd13cee68771e6366440a005f919ef4a48e7c7b.tar.gz
historical-ccd13cee68771e6366440a005f919ef4a48e7c7b.tar.bz2
historical-ccd13cee68771e6366440a005f919ef4a48e7c7b.zip
update glx-fix.patch for 0.81.1 (bug #48470)
Diffstat (limited to 'games-emulation/xmame')
-rw-r--r--games-emulation/xmame/ChangeLog6
-rw-r--r--games-emulation/xmame/Manifest5
-rw-r--r--games-emulation/xmame/files/0.81.1-glx-fix.patch11
-rw-r--r--games-emulation/xmame/xmame-0.81.1.ebuild5
4 files changed, 22 insertions, 5 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index 2ca1a7b43cd4..77291fd70040 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/xmame
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.17 2004/04/19 10:31:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.18 2004/04/21 06:02:59 mr_bones_ Exp $
+
+ 20 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.81.1.ebuild,
+ files/0.81.1-glx-fix.patch:
+ update glx-fix.patch for 0.81.1 (bug #48470)
*xmame-0.81.1 (19 Apr 2004)
diff --git a/games-emulation/xmame/Manifest b/games-emulation/xmame/Manifest
index 7d9245a3f981..db6b9259f507 100644
--- a/games-emulation/xmame/Manifest
+++ b/games-emulation/xmame/Manifest
@@ -1,5 +1,5 @@
-MD5 da61878439c56507b9a3d063bfe49027 ChangeLog 5661
-MD5 724b3fa5f76ad33e3b3cadc818f16a92 xmame-0.81.1.ebuild 6444
+MD5 87c39e61487c3ee789d7723430cec7c0 ChangeLog 5815
+MD5 ffea799fa442b38b02185d50ceb59a42 xmame-0.81.1.ebuild 6484
MD5 9f4c00afb295a5316c4049f8775d3d79 xmame-0.78.1.ebuild 6412
MD5 9baf5167bac7708cc8844d9a73344e2b xmame-0.79.1.ebuild 6768
MD5 9b2a69b3aa38e43d7daa86d868406523 xmame-0.80.1.ebuild 6784
@@ -18,3 +18,4 @@ MD5 13dc5b32bbff98dec74c41dd0c9b33a1 files/0.80.1-glx-fix.patch 597
MD5 a956d1afa6724941d56732f2b91f42eb files/0.80.1-make.patch 1243
MD5 e6d34df3a2c4a7f74b4853084f9b363e files/digest-xmame-0.80.1 67
MD5 9890e1cb0e82b29fde141274f5ce5eec files/digest-xmame-0.81.1 67
+MD5 240bd404f0deb6cd68bf6a98a5fb76db files/0.81.1-glx-fix.patch 386
diff --git a/games-emulation/xmame/files/0.81.1-glx-fix.patch b/games-emulation/xmame/files/0.81.1-glx-fix.patch
new file mode 100644
index 000000000000..cbcb32d8a7dc
--- /dev/null
+++ b/games-emulation/xmame/files/0.81.1-glx-fix.patch
@@ -0,0 +1,11 @@
+--- src/unix/osd_cpu.h.orig 2004-04-20 14:30:49.000000000 -0700
++++ src/unix/osd_cpu.h 2004-04-20 14:31:48.000000000 -0700
+@@ -38,7 +38,7 @@
+ #endif
+ #endif
+
+-#ifndef __ARCH_solaris
++#if !defined __ARCH_solaris && !defined xgl
+ /* grrr work around some stupid header conflicts */
+ #if !defined __XF86_DGA_C && !defined __XOPENGL_C_ && !defined LONG64
+ typedef signed char INT8;
diff --git a/games-emulation/xmame/xmame-0.81.1.ebuild b/games-emulation/xmame/xmame-0.81.1.ebuild
index a1655ff9af80..ad991b66a7cf 100644
--- a/games-emulation/xmame/xmame-0.81.1.ebuild
+++ b/games-emulation/xmame/xmame-0.81.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.81.1.ebuild,v 1.1 2004/04/19 10:31:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.81.1.ebuild,v 1.2 2004/04/21 06:02:59 mr_bones_ Exp $
-inherit games flag-o-matic gcc eutils
+inherit flag-o-matic gcc eutils games
TARGET="${PN}"
@@ -36,6 +36,7 @@ S="${WORKDIR}/xmame-${PV}"
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${PV}-glx-fix.patch
sed -i \
-e 's:JOY_BUTTONS 16:JOY_BUTTONS 32:' src/unix/devices.h \
|| die "setting joybuttons failed" #36818