summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2006-10-15 23:12:31 +0000
committerTristan Heaven <tristan@gentoo.org>2006-10-15 23:12:31 +0000
commitc8694d03a835d8af843ccae76acbb21e54799428 (patch)
tree6fd61aae738effa7b1810dc63d9ff7d0863ca0a9 /games-emulation/vgba/vgba-3.0.ebuild
parentMarking amd64 stable (diff)
downloadhistorical-c8694d03a835d8af843ccae76acbb21e54799428.tar.gz
historical-c8694d03a835d8af843ccae76acbb21e54799428.tar.bz2
historical-c8694d03a835d8af843ccae76acbb21e54799428.zip
Version bump
Package-Manager: portage-2.1.2_pre3-r2
Diffstat (limited to 'games-emulation/vgba/vgba-3.0.ebuild')
-rw-r--r--games-emulation/vgba/vgba-3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-emulation/vgba/vgba-3.0.ebuild b/games-emulation/vgba/vgba-3.0.ebuild
new file mode 100644
index 000000000000..3a4ba1f2cf35
--- /dev/null
+++ b/games-emulation/vgba/vgba-3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vgba/vgba-3.0.ebuild,v 1.1 2006/10/15 23:12:31 nyhm Exp $
+
+inherit games
+
+DESCRIPTION="Gameboy Advance (GBA) emulator for Linux"
+HOMEPAGE="http://www.komkon.org/fms/VGBA/"
+SRC_URI="http://fms.komkon.org/VGBA/VGBA${PV/.}-Linux-80x86-bin.tar.Z"
+
+LICENSE="VGBA"
+SLOT="0"
+KEYWORDS="-* ~x86"
+RESTRICT="strip"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+
+S=${WORKDIR}
+
+src_install() {
+ into "${GAMES_PREFIX_OPT}"
+ dobin vgba || die "dobin failed"
+ dohtml VGBA.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "You must run X in 16bit color for the emu to work"
+ echo
+}