summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-18 16:25:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-18 16:25:48 +0000
commit28e1fae973b35817291ca2551fa640fae05727a7 (patch)
tree88510869528784c8cfa8da02976d5e63d57f993d /games-emulation/mupen64-glide64
parentMoved net-www/w3mir to www-client/w3mir (diff)
downloadhistorical-28e1fae973b35817291ca2551fa640fae05727a7.tar.gz
historical-28e1fae973b35817291ca2551fa640fae05727a7.tar.bz2
historical-28e1fae973b35817291ca2551fa640fae05727a7.zip
fix bad epatch logic (bug #85739); fix deps; tidy ebuild
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-emulation/mupen64-glide64')
-rw-r--r--games-emulation/mupen64-glide64/ChangeLog6
-rw-r--r--games-emulation/mupen64-glide64/Manifest4
-rw-r--r--games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild34
3 files changed, 27 insertions, 17 deletions
diff --git a/games-emulation/mupen64-glide64/ChangeLog b/games-emulation/mupen64-glide64/ChangeLog
index 99b456f31121..7c1520acbc02 100644
--- a/games-emulation/mupen64-glide64/ChangeLog
+++ b/games-emulation/mupen64-glide64/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64-glide64
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/ChangeLog,v 1.5 2005/01/20 04:22:22 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/ChangeLog,v 1.6 2005/03/18 16:25:48 mr_bones_ Exp $
+
+ 18 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ mupen64-glide64-0.7.ebuild:
+ fix bad epatch logic (bug #85739); fix deps; tidy ebuild
19 Jan 2005; Daniel Goller <morfic@gentoo.org> mupen64-glide64-0.7.ebuild:
Stable on x86
diff --git a/games-emulation/mupen64-glide64/Manifest b/games-emulation/mupen64-glide64/Manifest
index 834d689470b6..d28819557955 100644
--- a/games-emulation/mupen64-glide64/Manifest
+++ b/games-emulation/mupen64-glide64/Manifest
@@ -1,6 +1,6 @@
-MD5 3588f7130a60170eb07ba4741814d447 ChangeLog 1022
+MD5 6af7e3165d6f706418091fe3a5c4b29f ChangeLog 1170
MD5 a3e62bf537d9a02609601aa9ba76da7e metadata.xml 247
-MD5 8ea68be414e1805b39e8a946bf11f97d mupen64-glide64-0.7.ebuild 1234
+MD5 f728149cd021f180256dcabf11339c53 mupen64-glide64-0.7.ebuild 1284
MD5 ea5cfac2f37f3bea3a5a9ac9b6c06854 files/digest-mupen64-glide64-0.7 67
MD5 2f68b9e4d03102e87c1b845f4112b051 files/mupen64-glide64-0.7-compile.patch 4677
MD5 791bcffd2d51c09bb816d5449bf5ca91 files/mupen64-glide64-0.7-gtk2.patch 1544
diff --git a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
index ca18b9ab00e0..c60b71839159 100644
--- a/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
+++ b/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
@@ -1,43 +1,49 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.5 2005/01/31 03:27:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.6 2005/03/18 16:25:48 mr_bones_ Exp $
inherit flag-o-matic eutils games
+MY_P="glide64_${PV/./_}_ME"
DESCRIPTION="An opengl graphics plugin for the mupen64 N64 emulator"
HOMEPAGE="http://mupen64.emulation64.com/"
-SRC_URI="mirror://gentoo/glide64_0_7_ME.tar.bz2"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE="gtk2"
-DEPEND=""
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ gtk2? ( >=x11-libs/gtk+-2 )
+ !gtk2? ( =x11-libs/gtk+-1.2* )"
-S="${WORKDIR}/glide64_0_7_ME"
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
+ cd "${S}"
- cd ${S}
-
- epatch ${FILESDIR}/${P}-compile.patch || die "patch failed"
- epatch ${FILESDIR}/${P}-inifix.patch || die "patch failed"
- use gtk2 && epatch ${FILESDIR}/${P}-gtk2.patch || die "patch failed"
+ epatch "${FILESDIR}/${P}-compile.patch"
+ epatch "${FILESDIR}/${P}-inifix.patch"
+ if use gtk2; then
+ epatch "${FILESDIR}/${P}-gtk2.patch"
+ fi
make clean || die "couldn't clean"
# gcc 3.4 at least has a problem with -O3 and inline asm
replace-flags -O3 -O2
- sed -i -e "s:CFLAGS.*=\(.*\):CFLAGS=\1 ${CFLAGS}:" Makefile || \
- die "couldn't apply cflags"
-
+ sed -i \
+ -e "s:CFLAGS.*=\(.*\):CFLAGS=\1 ${CFLAGS}:" \
+ Makefile \
+ || die "sed failed"
}
src_compile() {
- # doesnt like -j2
- make || die "couldn't compile"
+ emake -j1 || die "emake failed"
}
src_install() {