summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-31 11:15:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-31 11:15:11 +0000
commit44704efebb91c831328d2cab23048d93f1122da6 (patch)
tree0ce3ec03207dbf7711c9884e9cc8a85a2013857d /games-emulation/kigb/kigb-1.68.ebuild
parentVersion bump thanks to affinity <waffinity@gmail.com> in bug #62039 (diff)
downloadhistorical-44704efebb91c831328d2cab23048d93f1122da6.tar.gz
historical-44704efebb91c831328d2cab23048d93f1122da6.tar.bz2
historical-44704efebb91c831328d2cab23048d93f1122da6.zip
version bump; use GAMES_PREFIX_OPT in wrapper script; tidy old versions
Diffstat (limited to 'games-emulation/kigb/kigb-1.68.ebuild')
-rw-r--r--games-emulation/kigb/kigb-1.68.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-emulation/kigb/kigb-1.68.ebuild b/games-emulation/kigb/kigb-1.68.ebuild
new file mode 100644
index 000000000000..4b9d7e8556ec
--- /dev/null
+++ b/games-emulation/kigb/kigb-1.68.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/kigb/kigb-1.68.ebuild,v 1.1 2004/08/31 11:15:11 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A Gameboy (GB, SGB, GBA) Emulator for Linux"
+HOMEPAGE="http://kigb.emuunlim.com"
+# No version upstream
+#SRC_URI="http://kigb.emuunlim.com/${PN}_lin.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+RDEPEND="virtual/libc
+ virtual/x11
+ sys-libs/zlib
+ dev-games/hawknl"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # use the system version
+ rm -f libNL.so*
+ # wrapper script creates these in the users' home directories.
+ rm -rf cfg inp snap state rom save
+ cp "${FILESDIR}/kigb" "${T}/" || die "cp failed"
+ sed -i \
+ -e "s:GENTOODIR:${GAMES_PREFIX_OPT}:" "${T}/kigb" \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin "${T}/kigb" || die "dogamesbin failed"
+ exeinto "${GAMES_PREFIX_OPT}/${PN}"
+ doexe kigb || die "doexe failed"
+ dodoc doc/*
+ prepgamesdirs
+}