summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commit4449c749e4d0a531f4dffcd6bd11772e59ecbf81 (patch)
tree47ac23a46562d1736503b9b2447f81b34199c04e /games-emulation/hatari
parentNew package - rename. (diff)
downloadhistorical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.tar.gz
historical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.tar.bz2
historical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/hatari')
-rw-r--r--games-emulation/hatari/ChangeLog19
-rw-r--r--games-emulation/hatari/Manifest3
-rw-r--r--games-emulation/hatari/files/digest-hatari-0.401
-rw-r--r--games-emulation/hatari/hatari-0.40.ebuild39
4 files changed, 62 insertions, 0 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
new file mode 100644
index 000000000000..3dbeea51d1d9
--- /dev/null
+++ b/games-emulation/hatari/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for app-emulation/hatari
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+ 03 Sep 2003; David Holm <dholm@gentoo.org> hatari-0.40.ebuild:
+ Added hatari to ~ppc.
+
+ 04 Aug 2003; Michael Sterrett <msterret@gentoo.org> hatari-0.40.ebuild:
+ tidy; error messages
+
+*hatari-0.40 (15 Jul 2003)
+
+ 15 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage #22095 + games.eclass support.
+
+*hatari-0.20.2 (11 Dec 2002)
+
+ 11 Dec 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+ initial release
diff --git a/games-emulation/hatari/Manifest b/games-emulation/hatari/Manifest
new file mode 100644
index 000000000000..33a26cfb122a
--- /dev/null
+++ b/games-emulation/hatari/Manifest
@@ -0,0 +1,3 @@
+MD5 de5d6e4c1148277f2bb18fe31e05fe42 ChangeLog 651
+MD5 c560e63395409219995e360f5bdfe9ee hatari-0.40.ebuild 952
+MD5 3e8a51349887e732bbc7c357a71afd70 files/digest-hatari-0.40 63
diff --git a/games-emulation/hatari/files/digest-hatari-0.40 b/games-emulation/hatari/files/digest-hatari-0.40
new file mode 100644
index 000000000000..b64568045a14
--- /dev/null
+++ b/games-emulation/hatari/files/digest-hatari-0.40
@@ -0,0 +1 @@
+MD5 afeaff145cdbff6a0342f0b0d467abc2 hatari-0.40.tar.gz 301057
diff --git a/games-emulation/hatari/hatari-0.40.ebuild b/games-emulation/hatari/hatari-0.40.ebuild
new file mode 100644
index 000000000000..a9a9dc4b803b
--- /dev/null
+++ b/games-emulation/hatari/hatari-0.40.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.40.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
+HOMEPAGE="http://hatari.sourceforge.net/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc"
+SLOT="0"
+
+DEPEND="media-libs/libsdl
+ sys-libs/zlib"
+
+src_compile() {
+ cd src
+ emake \
+ CMPLRFLAGS="${CFLAGS}" \
+ DATADIR=${GAMES_DATADIR}/${PN} \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${S}/src/hatari || die
+ dodoc *.txt doc/*.txt
+ dohtml doc/.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "You need a tos rom to run hatari, you can find EmuTOS here:"
+ einfo " http://emutos.sourceforge.net/ - Which is a free TOS implementation"
+ einfo "or, go here and get a real TOS:"
+ einfo " http://www.atari.st/"
+}