summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-20 20:28:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-20 20:28:23 +0000
commitca64e8c4da5d9cfce4b4c88167f86e5e28a0a18f (patch)
tree81a43069aca64259ef39011f4443734b14a7adb9 /games-emulation/gngeo/gngeo-0.6.12.ebuild
parentgnome-python-desktop blocks older gnome-python-extras. Bug #132596 (diff)
downloadhistorical-ca64e8c4da5d9cfce4b4c88167f86e5e28a0a18f.tar.gz
historical-ca64e8c4da5d9cfce4b4c88167f86e5e28a0a18f.tar.bz2
historical-ca64e8c4da5d9cfce4b4c88167f86e5e28a0a18f.zip
version bump
Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'games-emulation/gngeo/gngeo-0.6.12.ebuild')
-rw-r--r--games-emulation/gngeo/gngeo-0.6.12.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-emulation/gngeo/gngeo-0.6.12.ebuild b/games-emulation/gngeo/gngeo-0.6.12.ebuild
new file mode 100644
index 000000000000..8e3b71aeec94
--- /dev/null
+++ b/games-emulation/gngeo/gngeo-0.6.12.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.6.12.ebuild,v 1.1 2006/06/20 20:28:23 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A NeoGeo emulator"
+HOMEPAGE="http://m.peponas.free.fr/gngeo/"
+SRC_URI="http://m.peponas.free.fr/gngeo/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ sys-libs/zlib
+ media-libs/sdl-image
+ >=media-libs/libsdl-1.2"
+# gcc-3.3 gets it wrong - bug #128587
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.4
+ x86? ( >=dev-lang/nasm-0.98 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-execstacks.patch"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README sample_gngeorc
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "A licensed NeoGeo BIOS copy is required to run the emulator."
+ echo
+}