summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-25 06:41:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-25 06:41:25 +0000
commit43a28412a10eccfaacb5ee9e7c16f176afbd7169 (patch)
tree65e57ce74885f3e5abd2004ae5e3295d788b4a1e /games-emulation/game-launcher
parentversion bump unstable for bug 23274 (diff)
downloadhistorical-43a28412a10eccfaacb5ee9e7c16f176afbd7169.tar.gz
historical-43a28412a10eccfaacb5ee9e7c16f176afbd7169.tar.bz2
historical-43a28412a10eccfaacb5ee9e7c16f176afbd7169.zip
Added a patch from Brandy Westcott (via bug 13542)
Diffstat (limited to 'games-emulation/game-launcher')
-rw-r--r--games-emulation/game-launcher/ChangeLog7
-rw-r--r--games-emulation/game-launcher/Manifest7
-rw-r--r--games-emulation/game-launcher/files/0.9.8-gentoo.patch197
-rw-r--r--games-emulation/game-launcher/game-launcher-0.9.8.ebuild15
4 files changed, 211 insertions, 15 deletions
diff --git a/games-emulation/game-launcher/ChangeLog b/games-emulation/game-launcher/ChangeLog
index 6e55ee504e88..9adccdcce62c 100644
--- a/games-emulation/game-launcher/ChangeLog
+++ b/games-emulation/game-launcher/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/game-launcher
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/game-launcher/ChangeLog,v 1.2 2003/09/10 16:01:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/game-launcher/ChangeLog,v 1.3 2003/09/25 06:41:23 msterret Exp $
+
+ 24 Sep 2003; Michael Sterrett <msterret@gentoo.org>
+ game-launcher-0.9.8.ebuild, files/0.9.8-gentoo.patch:
+ Added a patch from Brandy Westcott (via bug 13542); rolled up the patches in to
+ a Gentoo patch; some cleanup in the ebuild
21 Aug 2003; Michael Sterrett <msterret@gentoo.org>
game-launcher-0.9.8.ebuild:
diff --git a/games-emulation/game-launcher/Manifest b/games-emulation/game-launcher/Manifest
index 9051a77c51a1..40236926c458 100644
--- a/games-emulation/game-launcher/Manifest
+++ b/games-emulation/game-launcher/Manifest
@@ -1,5 +1,6 @@
-MD5 79514d6adf8fd7f9d6fc78210cc91aee files/digest-game-launcher-0.9.8 55
+MD5 5074dd03125a33bb863d08a0a20286d0 ChangeLog 1018
+MD5 900c175b8e5c77de18acba5138cd02e2 game-launcher-0.9.8.ebuild 1157
MD5 671b1311f9989ac4e746ae60042ec36c files/0.9.8-digi-oss.patch 229
MD5 0ce1a828196b8d4e3e0302ed4d95c4d3 files/0.9.8-gcc3.patch 299
-MD5 1babf98f1942fb5b35ac51d3840553bb ChangeLog 778
-MD5 d630bef028fe91c0940399574af3b3e9 game-launcher-0.9.8.ebuild 1317
+MD5 79514d6adf8fd7f9d6fc78210cc91aee files/digest-game-launcher-0.9.8 55
+MD5 fe19d89e23c88c3309c2a323e0b4f7f4 files/0.9.8-gentoo.patch 6097
diff --git a/games-emulation/game-launcher/files/0.9.8-gentoo.patch b/games-emulation/game-launcher/files/0.9.8-gentoo.patch
new file mode 100644
index 000000000000..043482db293a
--- /dev/null
+++ b/games-emulation/game-launcher/files/0.9.8-gentoo.patch
@@ -0,0 +1,197 @@
+diff -ru glaunch.orig/common.mk glaunch/common.mk
+--- glaunch.orig/common.mk 2002-05-14 21:28:18.000000000 -0700
++++ glaunch/common.mk 2003-09-24 16:22:28.000000000 -0700
+@@ -3,8 +3,8 @@
+
+ # Uncomment one target
+ #TARGET = DJGPP
+-TARGET = MINGW
+-#TARGET = UNIX
++#TARGET = MINGW
++TARGET = UNIX
+
+ # To disable feature, set to zero (0)
+ USE_TTF = 1
+diff -ru glaunch.orig/control/gl_key.cc glaunch/control/gl_key.cc
+--- glaunch.orig/control/gl_key.cc 2003-09-24 16:20:24.000000000 -0700
++++ glaunch/control/gl_key.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -2,6 +2,8 @@
+ #include "gl_key.h"
+ #include "allegro.h"
+
++using namespace std;
++
+ typedef map<int, int> GlKeyMap;
+
+ static GlKeyMap * glToAllegroMap = 0;
+diff -ru glaunch.orig/engine/engine.cc glaunch/engine/engine.cc
+--- glaunch.orig/engine/engine.cc 2003-09-24 16:20:25.000000000 -0700
++++ glaunch/engine/engine.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -1,3 +1,4 @@
++#define ALLEGRO_WITH_OSSDIGI
+ #include <iostream>
+ #include <strstream>
+ #include <stdlib.h>
+diff -ru glaunch.orig/include/mamescan.h glaunch/include/mamescan.h
+--- glaunch.orig/include/mamescan.h 2003-09-24 16:20:25.000000000 -0700
++++ glaunch/include/mamescan.h 2003-09-24 16:24:24.000000000 -0700
+@@ -1,12 +1,15 @@
+ #ifndef _ENGINE_H_
+ #define _ENGINE_H_
+
++#include <ctype.h>
+ #include <string>
+ #include <map>
+ #include <vector>
+
+ namespace MameScan
+ {
++ using namespace std;
++
+ typedef enum { GOOD, PRELIMINARY } GameStatus;
+
+ class Exception
+diff -ru glaunch.orig/include/outline.h glaunch/include/outline.h
+--- glaunch.orig/include/outline.h 2003-09-24 16:20:25.000000000 -0700
++++ glaunch/include/outline.h 2003-09-24 16:22:28.000000000 -0700
+@@ -9,6 +9,7 @@
+ */
+ namespace Outline
+ {
++ using namespace std;
+ /**
+ * Calculates the height of the font taking into account the extra
+ * padding of the outline.
+diff -ru glaunch.orig/mamescan/options.h glaunch/mamescan/options.h
+--- glaunch.orig/mamescan/options.h 2003-09-24 16:20:25.000000000 -0700
++++ glaunch/mamescan/options.h 2003-09-24 16:22:28.000000000 -0700
+@@ -4,6 +4,8 @@
+ #include "getopt.h"
+ #include <string>
+
++using namespace std;
++
+ // This is a singleton class
+
+ class Options
+diff -ru glaunch.orig/model/emulator.cc glaunch/model/emulator.cc
+--- glaunch.orig/model/emulator.cc 2003-09-24 16:20:25.000000000 -0700
++++ glaunch/model/emulator.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -2,8 +2,8 @@
+ #include <dirent.h>
+ #include <fstream>
+
+-#include "fileutil.h"
+ #include "glaunch.h"
++#include "fileutil.h"
+ #include "logfile.h"
+
+ using namespace GameLauncher;
+@@ -63,7 +63,7 @@
+
+ Emulator::Emulator(const string & config_name,
+ const string & path_prefix,
+- Emulator_Listener * listener = 0
++ Emulator_Listener * listener
+ ) throw (InvalidEmulatorConfig)
+ : p_name_map(), p_games()
+ {
+@@ -612,7 +612,7 @@
+ }
+
+ InvalidEmulator::InvalidEmulator(const string & config_name,
+- Emulator_Listener * listener = 0)
++ Emulator_Listener * listener)
+ : Emulator()
+ {
+ if (listener != 0)
+diff -ru glaunch.orig/model/emumgr.cc glaunch/model/emumgr.cc
+--- glaunch.orig/model/emumgr.cc 2003-09-24 16:20:25.000000000 -0700
++++ glaunch/model/emumgr.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -1,6 +1,6 @@
++#include "glaunch.h"
+ #include "logfile.h"
+ #include "fileutil.h"
+-#include "glaunch.h"
+
+ using namespace GameLauncher;
+ using namespace std;
+diff -ru glaunch.orig/model/game.cc glaunch/model/game.cc
+--- glaunch.orig/model/game.cc 2003-09-24 16:20:25.000000000 -0700
++++ glaunch/model/game.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -1,5 +1,5 @@
+-#include "logfile.h"
+ #include "glaunch.h"
++#include "logfile.h"
+
+ using namespace GameLauncher;
+ using namespace std;
+diff -ru glaunch.orig/startup/unix/glaunch.cc glaunch/startup/unix/glaunch.cc
+--- glaunch.orig/startup/unix/glaunch.cc 2003-09-24 16:20:25.000000000 -0700
++++ glaunch/startup/unix/glaunch.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -5,6 +5,8 @@
+ #include "exit.h"
+ #include <stdio.h>
+
++using namespace std;
++
+ static int runProgram(const char * program);
+
+ int main(int argc, char *argv[])
+diff -ru glaunch.orig/view/movebmp.cc glaunch/view/movebmp.cc
+--- glaunch.orig/view/movebmp.cc 2003-09-24 16:20:26.000000000 -0700
++++ glaunch/view/movebmp.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -132,7 +132,7 @@
+ }
+
+ void
+-Movable_Bitmap::move_to(int x, int y, int milliseconds = 0)
++Movable_Bitmap::move_to(int x, int y, int milliseconds)
+ {
+ fix num_game_ticks;
+
+diff -ru glaunch.orig/view/movetext.cc glaunch/view/movetext.cc
+--- glaunch.orig/view/movetext.cc 2003-09-24 16:20:26.000000000 -0700
++++ glaunch/view/movetext.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -54,7 +54,7 @@
+ }
+
+ void
+-Text_VC::set_contents(const string & text, BITMAP * icon = 0)
++Text_VC::set_contents(const string & text, BITMAP * icon)
+ {
+ char * end;
+ int max_width;
+diff -ru glaunch.orig/view/mp3bg.cc glaunch/view/mp3bg.cc
+--- glaunch.orig/view/mp3bg.cc 2003-09-24 16:20:26.000000000 -0700
++++ glaunch/view/mp3bg.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -195,7 +195,7 @@
+ }
+
+ void
+-MP3_Background_Almp3_File::seek(unsigned index, int position = 0)
++MP3_Background_Almp3_File::seek(unsigned index, int position)
+ {
+ bool was_running;
+
+@@ -457,7 +457,7 @@
+ }
+
+ void
+-MP3_Background_Almp3_Stream::seek(unsigned index, int position = 0)
++MP3_Background_Almp3_Stream::seek(unsigned index, int position)
+ {
+ bool was_running;
+
+diff -ru glaunch.orig/view/sshot.cc glaunch/view/sshot.cc
+--- glaunch.orig/view/sshot.cc 2003-09-24 16:20:26.000000000 -0700
++++ glaunch/view/sshot.cc 2003-09-24 16:22:28.000000000 -0700
+@@ -101,7 +101,7 @@
+
+ void
+ Screen_Shot::set_bitmap(const string & bitmap_file, fix brightness_percentage,
+- int delay = 0)
++ int delay)
+ {
+ p_new_bitmap_file = bitmap_file;
+ p_brightness_percentage = brightness_percentage;
diff --git a/games-emulation/game-launcher/game-launcher-0.9.8.ebuild b/games-emulation/game-launcher/game-launcher-0.9.8.ebuild
index e40f21655169..db7145103190 100644
--- a/games-emulation/game-launcher/game-launcher-0.9.8.ebuild
+++ b/games-emulation/game-launcher/game-launcher-0.9.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/game-launcher/game-launcher-0.9.8.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/game-launcher/game-launcher-0.9.8.ebuild,v 1.2 2003/09/25 06:41:23 msterret Exp $
inherit games eutils
@@ -20,7 +20,6 @@ RDEPEND=">=media-libs/allegro-4.0.0
>=media-libs/jpgalleg-1.1
>=sys-libs/zlib-1.1.4"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4
app-arch/unzip"
S=${WORKDIR}/glaunch
@@ -30,18 +29,12 @@ src_unpack() {
cd ${S}
edos2unix `find -regex '.*\.[ch]' -or -name '*.cc'`
-
- epatch ${FILESDIR}/${PV}-gcc3.patch
- epatch ${FILESDIR}/${PV}-digi-oss.patch
-
- sed -i \
- -e "s/TARGET\(.*\)= MINGW/#TARGET\1= MINGW/" \
- -e "s/#TARGET\(.*\)= UNIX/TARGET\1= UNIX/" common.mk || \
- die "sed common.mk failed"
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+ find . -name ".cvsignore" -exec rm -f \{\} \;
}
src_compile() {
- emake -j1 CXXFLAGS="${CXXFLAGS}"
+ emake -j1 || die "emake failed"
}
src_install() {