summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-27 02:58:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-27 02:58:10 +0000
commitb732c97d64e7624c89f016d8058290e096ee5c38 (patch)
tree7592b52271f0f33f239f241783e3b106a7012625 /games-emulation/fbzx/fbzx-1.4.ebuild
parentstable on ppc64 (diff)
downloadhistorical-b732c97d64e7624c89f016d8058290e096ee5c38.tar.gz
historical-b732c97d64e7624c89f016d8058290e096ee5c38.tar.bz2
historical-b732c97d64e7624c89f016d8058290e096ee5c38.zip
fix endian issues #61531
Diffstat (limited to 'games-emulation/fbzx/fbzx-1.4.ebuild')
-rw-r--r--games-emulation/fbzx/fbzx-1.4.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/games-emulation/fbzx/fbzx-1.4.ebuild b/games-emulation/fbzx/fbzx-1.4.ebuild
index 861c052101b0..c1162dbef920 100644
--- a/games-emulation/fbzx/fbzx-1.4.ebuild
+++ b/games-emulation/fbzx/fbzx-1.4.ebuild
@@ -1,32 +1,38 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.4.ebuild,v 1.4 2004/06/24 22:26:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.4.ebuild,v 1.5 2004/08/27 02:58:10 vapier Exp $
-inherit games
+inherit games eutils gcc
-S="${WORKDIR}/${PN}"
DESCRIPTION="A Sinclair Spectrum emulator, designed to work at full screen using the FrameBuffer"
HOMEPAGE="http://www.rastersoft.com/fbzx.html"
SRC_URI="http://www.rastersoft.com/programas/fbzx/${PN}14.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
SLOT="0"
+KEYWORDS="x86 ~ppc"
IUSE=""
RDEPEND="media-libs/libsdl"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
+S="${WORKDIR}/${PN}"
+
src_unpack() {
unpack ${A}
cd ${S}
sed -i \
- -e "s|/usr/share/spectrum|${GAMES_DATADIR}/${PN}|g" emulator.c \
- || die "sed failed"
+ -e "s|/usr/share/spectrum|${GAMES_DATADIR}/${PN}|g" \
+ emulator.c || die "sed failed"
+ sed -i \
+ -e "s:gcc:$(gcc-getCC):" \
+ -e "s:-O2:${CFLAGS}:" \
+ Makefile
+ epatch ${FILESDIR}/${PV}-endian.patch
}
-src_install () {
+src_install() {
dogamesbin fbzx || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}/roms"
doins roms/* || die "doins failed"