summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-11 02:55:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-11 02:55:42 +0000
commit4805fdcceaf7dcbbc02172efa081491bc32b7a13 (patch)
tree48ef65f0c71def3c3fa2fbbf89fc9568a3f70e8d /games-emulation/dosbox
parentfixing Manifest (diff)
downloadhistorical-4805fdcceaf7dcbbc02172efa081491bc32b7a13.tar.gz
historical-4805fdcceaf7dcbbc02172efa081491bc32b7a13.tar.bz2
historical-4805fdcceaf7dcbbc02172efa081491bc32b7a13.zip
add back in 0.58 since it supports more games than 0.6x
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/dosbox-0.58.ebuild30
-rw-r--r--games-emulation/dosbox/dosbox-0.61.ebuild6
-rw-r--r--games-emulation/dosbox/files/digest-dosbox-0.581
3 files changed, 34 insertions, 3 deletions
diff --git a/games-emulation/dosbox/dosbox-0.58.ebuild b/games-emulation/dosbox/dosbox-0.58.ebuild
new file mode 100644
index 000000000000..94395f793a75
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.58.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.58.ebuild,v 1.3 2004/02/11 02:55:42 vapier Exp $
+
+inherit games
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="sys-libs/ncurses
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+ prepgamesdirs
+}
diff --git a/games-emulation/dosbox/dosbox-0.61.ebuild b/games-emulation/dosbox/dosbox-0.61.ebuild
index 8c63bda33b07..8a1e87822de3 100644
--- a/games-emulation/dosbox/dosbox-0.61.ebuild
+++ b/games-emulation/dosbox/dosbox-0.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.61.ebuild,v 1.2 2004/02/04 02:56:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.61.ebuild,v 1.3 2004/02/11 02:55:42 vapier Exp $
inherit games
@@ -33,7 +33,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS || die "dodoc failed"
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
prepgamesdirs
}
diff --git a/games-emulation/dosbox/files/digest-dosbox-0.58 b/games-emulation/dosbox/files/digest-dosbox-0.58
new file mode 100644
index 000000000000..d69a70486cca
--- /dev/null
+++ b/games-emulation/dosbox/files/digest-dosbox-0.58
@@ -0,0 +1 @@
+MD5 91c49a597134f35f899d32a8b253205b dosbox-0.58.tar.gz 421487