summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-05-31 18:33:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-05-31 18:33:39 +0000
commitfe284c36811376822c5d5a7d87f6ac3bc8564230 (patch)
treef7332784c7750f056c58ee38b43723c83f13aee0 /games-board
parentStable on sparc (diff)
downloadhistorical-fe284c36811376822c5d5a7d87f6ac3bc8564230.tar.gz
historical-fe284c36811376822c5d5a7d87f6ac3bc8564230.tar.bz2
historical-fe284c36811376822c5d5a7d87f6ac3bc8564230.zip
version bump (bug #94641)
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog7
-rw-r--r--games-board/crafty/Manifest4
-rw-r--r--games-board/crafty/crafty-19.19.ebuild76
-rw-r--r--games-board/crafty/files/digest-crafty-19.191
4 files changed, 86 insertions, 2 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index 6db57c1b400b..61c5d3922490 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.10 2005/04/12 04:52:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.11 2005/05/31 18:33:39 mr_bones_ Exp $
+
+*crafty-19.19 (31 May 2005)
+
+ 31 May 2005; Michael Sterrett <mr_bones_@gentoo.org> +crafty-19.19.ebuild:
+ version bump (bug #94641)
*crafty-19.18 (12 Apr 2005)
diff --git a/games-board/crafty/Manifest b/games-board/crafty/Manifest
index 8518e84de3a2..cf6bf3d50e14 100644
--- a/games-board/crafty/Manifest
+++ b/games-board/crafty/Manifest
@@ -1,10 +1,12 @@
MD5 19e701c1670f8db20f5fda820dae8202 crafty-19.12.ebuild 2068
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 4baf57f031f8bf245b796ba855b6f85a crafty-19.19.ebuild 2280
MD5 f03686b9106ca9dc98600eaf2184df88 crafty-19.15.ebuild 2318
MD5 0b2ca3079bab31b591bff65474c2c978 crafty-19.18.ebuild 2308
-MD5 0314ac36353ac4610f29a6613a46584e ChangeLog 1752
+MD5 5923db5db61e4f4e29094ecd5c0bff97 ChangeLog 1887
MD5 de0523025198eaab0a6cc8477f86a76b crafty-19.1.ebuild 2280
MD5 3505ffbd5c4bb22f2789ff8c96979fb6 crafty-19.8.ebuild 2113
+MD5 901b6df7332530910e854f501d4d49e1 files/digest-crafty-19.19 64
MD5 4970593053a51ce5e26ea2d6bd89ffe9 files/19.8-ppc.patch 702
MD5 3dceccb949c1ffd0e0c563eaaa3ee237 files/digest-crafty-19.12 64
MD5 ab7c7d5b9120c4cbf728cfc3fd8c83cf files/digest-crafty-19.18 64
diff --git a/games-board/crafty/crafty-19.19.ebuild b/games-board/crafty/crafty-19.19.ebuild
new file mode 100644
index 000000000000..d5f87c5f7053
--- /dev/null
+++ b/games-board/crafty/crafty-19.19.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-19.19.ebuild,v 1.1 2005/05/31 18:33:39 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.tar.gz"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="icc no-opts"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ icc? ( >=dev-lang/icc-5.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if use icc ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [ "${CHOST}" == "i686-pc-linux-gnu" ] || [ "${CHOST}" == "i586-pc-linux-gnu" ] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fforce-mem -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="-lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp || die "doins failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo
+ einfo "Note: No books or tablebases have been installed. If you want them, just"
+ einfo " download them from ${HOMEPAGE}."
+ einfo " You will find documentation there too. In most cases you take now "
+ einfo " your xboard compatible application, (xboard, eboard, knights) and "
+ einfo " just play chess against computer opponent. Have fun."
+ einfo
+}
diff --git a/games-board/crafty/files/digest-crafty-19.19 b/games-board/crafty/files/digest-crafty-19.19
new file mode 100644
index 000000000000..debe738532a6
--- /dev/null
+++ b/games-board/crafty/files/digest-crafty-19.19
@@ -0,0 +1 @@
+MD5 f0cbd39ae11e2ecd6a439226c9b10b59 crafty-19.19.tar.gz 395480