summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-27 18:26:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-27 18:26:30 +0000
commit7045c41ea6178fe17bfa9bce8e08707a1081ede1 (patch)
treee746eac3d68bc9fc664b8fe60397f0e0e4408eb5 /games-board
parentadd a couple of ewarns to improve readability (diff)
downloadhistorical-7045c41ea6178fe17bfa9bce8e08707a1081ede1.tar.gz
historical-7045c41ea6178fe17bfa9bce8e08707a1081ede1.tar.bz2
historical-7045c41ea6178fe17bfa9bce8e08707a1081ede1.zip
version bump
Package-Manager: portage-2.0.53
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pio/ChangeLog7
-rw-r--r--games-board/pio/Manifest4
-rw-r--r--games-board/pio/files/digest-pio-0.9.401
-rw-r--r--games-board/pio/pio-0.9.40.ebuild36
4 files changed, 46 insertions, 2 deletions
diff --git a/games-board/pio/ChangeLog b/games-board/pio/ChangeLog
index bb387526a5f7..062e50d780ec 100644
--- a/games-board/pio/ChangeLog
+++ b/games-board/pio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/pio
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pio/ChangeLog,v 1.7 2005/11/22 17:14:12 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/ChangeLog,v 1.8 2005/12/27 18:26:30 mr_bones_ Exp $
+
+*pio-0.9.40 (27 Dec 2005)
+
+ 27 Dec 2005; Michael Sterrett <mr_bones_@gentoo.org> +pio-0.9.40.ebuild:
+ version bump
22 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org> pio-0.9.33.ebuild:
Marked stable on amd64 and x86 wrt bug #109084.
diff --git a/games-board/pio/Manifest b/games-board/pio/Manifest
index ac17dfacf844..36b4650ab851 100644
--- a/games-board/pio/Manifest
+++ b/games-board/pio/Manifest
@@ -1,8 +1,10 @@
-MD5 426935ff78fc4272a4cdbdd1a2997b8b ChangeLog 837
+MD5 8cec89b8192bc45aa7342bc38ba1a01a ChangeLog 956
MD5 a270a5b020f0b2c049fe47b0396bafd9 files/digest-pio-0.9.19 68
MD5 bd0fefda62535dc61a6c2791b5b194f8 files/digest-pio-0.9.23 68
MD5 1aa79202dcebe05379ba182e2f361d44 files/digest-pio-0.9.33 68
+MD5 1b814dcc402548c41406881d805130e9 files/digest-pio-0.9.40 68
MD5 7035b4db1ed5ed0e55ee3dd6524e5b2b metadata.xml 321
MD5 71a6059bd11e6bb1dc95370eb1cc128a pio-0.9.19.ebuild 1048
MD5 4a2092784b8521003ff632cf3b614cae pio-0.9.23.ebuild 1127
MD5 b4c874fb6338e72393001b19e4ca8d77 pio-0.9.33.ebuild 1124
+MD5 b0419c569f844b1bca4a5f6990b40902 pio-0.9.40.ebuild 898
diff --git a/games-board/pio/files/digest-pio-0.9.40 b/games-board/pio/files/digest-pio-0.9.40
new file mode 100644
index 000000000000..ba9aeac7cb64
--- /dev/null
+++ b/games-board/pio/files/digest-pio-0.9.40
@@ -0,0 +1 @@
+MD5 fd6ed4753d9e3103fda429ad5bcc50e8 pioneers-0.9.40.tar.gz 2156282
diff --git a/games-board/pio/pio-0.9.40.ebuild b/games-board/pio/pio-0.9.40.ebuild
new file mode 100644
index 000000000000..af85ef8486db
--- /dev/null
+++ b/games-board/pio/pio-0.9.40.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/pio-0.9.40.ebuild,v 1.1 2005/12/27 18:26:30 mr_bones_ Exp $
+
+inherit eutils gnome2
+
+MY_P="pioneers-${PV}"
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://pio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pio/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.4
+ >=gnome-base/libgnome-2.10
+ >=x11-libs/gtk+-2.4
+ >=app-text/scrollkeeper-0.3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ export G2CONF="${G2CONF} $(use_enable nls)"
+ gnome2_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO NEWS"
+ USE_DESTDIR=1
+ gnome2_src_install scrollkeeper_localstate_dir="${D}"/var/lib/scrollkeeper/
+}