summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-16 19:39:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-16 19:39:25 +0000
commit56748d367a8a4c16b94b38c21dfb7fa85d40ddc8 (patch)
tree1885d94be497e4d3d53c6905bd399e27d312dca5 /games-board/spider/spider-1.2_p4.ebuild
parent(non maintainer commit) fix tests when USE=gnome is present, bug 235849 by Mo... (diff)
downloadhistorical-56748d367a8a4c16b94b38c21dfb7fa85d40ddc8.tar.gz
historical-56748d367a8a4c16b94b38c21dfb7fa85d40ddc8.tar.bz2
historical-56748d367a8a4c16b94b38c21dfb7fa85d40ddc8.zip
initial commit - ebuild submitted by Michaĩ Wiernowolski via bug #96822
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.28.1 i686
Diffstat (limited to 'games-board/spider/spider-1.2_p4.ebuild')
-rw-r--r--games-board/spider/spider-1.2_p4.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/games-board/spider/spider-1.2_p4.ebuild b/games-board/spider/spider-1.2_p4.ebuild
new file mode 100644
index 000000000000..a1d98a3d511d
--- /dev/null
+++ b/games-board/spider/spider-1.2_p4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/spider/spider-1.2_p4.ebuild,v 1.1 2009/02/16 19:39:25 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_P="${P%%_*}"
+MY_P="${MY_P/-/_}"
+DEB_V="${P##*_p}"
+
+DESCRIPTION="Spider Solitaire"
+HOMEPAGE="http://packages.debian.org/stable/games/spider"
+SRC_URI="mirror://debian/pool/main/s/spider/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/s/spider/${MY_P}-${DEB_V}.diff.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="xaw"
+
+RDEPEND="x11-libs/libXext
+ xaw? ( x11-libs/libXaw )
+ x11-libs/libXmu
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P/_/-}.orig
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_P}-${DEB_V}.diff
+ rm Makefile
+}
+
+src_configure() {
+ imake \
+ -DUseInstalled \
+ -DSmallCards=NO \
+ -DRoundCards \
+ $(use xaw && echo "-DCompileXAW=YES" || echo "-DCompileXlibOnly=YES") \
+ -I/usr/lib/X11/config \
+ || die "imake failed"
+ sed -i \
+ -e '/CC = /d' \
+ -e '/CDEBUGFLAGS = /d' \
+ -e '/LDOPTIONS = /s/$/$(LDFLAGS)/' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ emake -j1 \
+ DESTDIR="${D}" \
+ BINDIR="${GAMES_BINDIR}" \
+ MANSUFFIX="6" \
+ MANDIR="/usr/share/man/man6" \
+ HELPDIR="/usr/share/doc/${PF}" \
+ install install.doc install.man \
+ || die "make install failed"
+
+ dodoc README* ChangeLog
+ newicon icons/Spider.png ${PN}.png
+ make_desktop_entry spider Spider
+ prepgamesdirs
+}