summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-11 05:30:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-11 05:30:29 +0000
commit7e8ffc75133abf8177dab8c3dc493e02c22a6a75 (patch)
treee9eff55895312d9c70b1389073d5055a7e677ee9 /games-arcade/xbubble
parentfile is stupid; punt it #63429 (diff)
downloadhistorical-7e8ffc75133abf8177dab8c3dc493e02c22a6a75.tar.gz
historical-7e8ffc75133abf8177dab8c3dc493e02c22a6a75.tar.bz2
historical-7e8ffc75133abf8177dab8c3dc493e02c22a6a75.zip
initial commit - ebuild based on the one provided by Alex Linke via bug #63566
Diffstat (limited to 'games-arcade/xbubble')
-rw-r--r--games-arcade/xbubble/ChangeLog10
-rw-r--r--games-arcade/xbubble/Manifest4
-rw-r--r--games-arcade/xbubble/files/digest-xbubble-0.5.81
-rw-r--r--games-arcade/xbubble/metadata.xml5
-rw-r--r--games-arcade/xbubble/xbubble-0.5.8.ebuild43
5 files changed, 63 insertions, 0 deletions
diff --git a/games-arcade/xbubble/ChangeLog b/games-arcade/xbubble/ChangeLog
new file mode 100644
index 000000000000..4ba6bbbfe582
--- /dev/null
+++ b/games-arcade/xbubble/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/xbubble
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/ChangeLog,v 1.1 2004/09/11 05:30:28 mr_bones_ Exp $
+
+*xbubble-0.5.8 (10 Sep 2004)
+
+ 10 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +xbubble-0.5.8.ebuild:
+ initial commit - ebuild based on the one provided by Alex Linke via bug #63566
+
diff --git a/games-arcade/xbubble/Manifest b/games-arcade/xbubble/Manifest
new file mode 100644
index 000000000000..5d2d796a1b16
--- /dev/null
+++ b/games-arcade/xbubble/Manifest
@@ -0,0 +1,4 @@
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 739b071808d8c1ca26525222c4787f6f xbubble-0.5.8.ebuild 991
+MD5 d292e12260a29494f39fa17b445c3871 ChangeLog 423
+MD5 ad5c558fae56fa370b8e01d0d5656c04 files/digest-xbubble-0.5.8 66
diff --git a/games-arcade/xbubble/files/digest-xbubble-0.5.8 b/games-arcade/xbubble/files/digest-xbubble-0.5.8
new file mode 100644
index 000000000000..a8fc59a54a30
--- /dev/null
+++ b/games-arcade/xbubble/files/digest-xbubble-0.5.8
@@ -0,0 +1 @@
+MD5 82de55a667ea3bed05967b937f3eace4 xbubble-0.5.8.tar.gz 5544359
diff --git a/games-arcade/xbubble/metadata.xml b/games-arcade/xbubble/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/xbubble/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/xbubble/xbubble-0.5.8.ebuild b/games-arcade/xbubble/xbubble-0.5.8.ebuild
new file mode 100644
index 000000000000..1f4eb74f8c54
--- /dev/null
+++ b/games-arcade/xbubble/xbubble-0.5.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/xbubble-0.5.8.ebuild,v 1.1 2004/09/11 05:30:28 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="a Puzzle Bobble clone similar to Frozen-Bubble"
+HOMEPAGE="http://www.nongnu.org/xbubble"
+SRC_URI="http://www.ibiblio.org/pub/mirrors/gnu/ftp/savannah/files/xbubble/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nls"
+
+DEPEND="virtual/x11
+ media-libs/libpng"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^AM_CFLAGS/d" src/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ || die
+ emake \
+ localedir="/usr/share/locale" \
+ || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" \
+ localedir="/usr/share/locale" \
+ install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS NetworkProtocol README TODO
+ prepgamesdirs
+}