summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2008-03-28 12:14:17 +0000
committerTristan Heaven <tristan@gentoo.org>2008-03-28 12:14:17 +0000
commit857690f61deaecae73ca8872a0d085db94636828 (patch)
treeb19236c7947eb64771f90c90f841410f09dab0ed /games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
parentUpdated the autotools patch to fix pkg-config file and fixed header directory... (diff)
downloadhistorical-857690f61deaecae73ca8872a0d085db94636828.tar.gz
historical-857690f61deaecae73ca8872a0d085db94636828.tar.bz2
historical-857690f61deaecae73ca8872a0d085db94636828.zip
Fix python eclass usage
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild')
-rw-r--r--games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
index 8b8583af4192..d3ebf5feb240 100644
--- a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
+++ b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.2 2008/02/29 18:52:02 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.3 2008/03/28 12:14:17 nyhm Exp $
NEED_PYTHON="2.4"
@@ -31,7 +31,7 @@ src_unpack() {
sed -i -e "s:data_dir\ =\ .*:data_dir\ =\ \"${GAMES_DATADIR}/${PN}\":" \
lib/data.py || die "Changing data path failed"
rm data/pictures/Thumbs.db
- }
+}
src_install() {
newgamesbin run_game.py ${PN} || die "newgamesbin failed"
@@ -50,7 +50,7 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize "$(games_get_libdir)/${PN}"
+ python_mod_optimize "${ROOT}$(games_get_libdir)/${PN}"
games_pkg_postinst
}