summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 22:50:01 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 22:50:01 +0000
commit38d49aa24e167ef5c7ce58e8842a87c7fe236987 (patch)
tree471f2e9fd77679922ae95c6c42b87d470ebf8bcd /games-arcade/penguin-command
parentStable on x86 (diff)
downloadhistorical-38d49aa24e167ef5c7ce58e8842a87c7fe236987.tar.gz
historical-38d49aa24e167ef5c7ce58e8842a87c7fe236987.tar.bz2
historical-38d49aa24e167ef5c7ce58e8842a87c7fe236987.zip
Add back in sound support since changelog says they fixed some things.
Package-Manager: portage-2.0.51.20-r5
Diffstat (limited to 'games-arcade/penguin-command')
-rw-r--r--games-arcade/penguin-command/ChangeLog10
-rw-r--r--games-arcade/penguin-command/Manifest6
-rw-r--r--games-arcade/penguin-command/files/digest-penguin-command-1.6.91
-rw-r--r--games-arcade/penguin-command/penguin-command-1.6.9.ebuild39
4 files changed, 52 insertions, 4 deletions
diff --git a/games-arcade/penguin-command/ChangeLog b/games-arcade/penguin-command/ChangeLog
index 8e79bcc180ad..763f37a0a292 100644
--- a/games-arcade/penguin-command/ChangeLog
+++ b/games-arcade/penguin-command/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/penguin-command
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/penguin-command/ChangeLog,v 1.10 2004/12/28 22:58:18 ciaranm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/penguin-command/ChangeLog,v 1.11 2005/04/29 22:50:01 vapier Exp $
+
+*penguin-command-1.6.9 (29 Apr 2005)
+
+ 29 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +penguin-command-1.6.9.ebuild:
+ Add back in sound support since changelog says they fixed some things.
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/games-arcade/penguin-command/Manifest b/games-arcade/penguin-command/Manifest
index 18b125331fc4..63ebd6b421cc 100644
--- a/games-arcade/penguin-command/Manifest
+++ b/games-arcade/penguin-command/Manifest
@@ -1,4 +1,6 @@
-MD5 31837dc063c5748d5bdd146bf4b130bf ChangeLog 1781
-MD5 43ac1e55b07a9f772814c695c0576ab9 penguin-command-1.6.6.ebuild 861
+MD5 8bb42537c38fc3b3e384a72869e2d130 ChangeLog 1975
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 43ac1e55b07a9f772814c695c0576ab9 penguin-command-1.6.6.ebuild 861
+MD5 ce5c6126150bc08aa65bb70b2f6a230e penguin-command-1.6.9.ebuild 1058
MD5 2708300e986624d9c0b4c5c9e41760c3 files/digest-penguin-command-1.6.6 74
+MD5 6b0f0c67ae6778539181fb73f07258b0 files/digest-penguin-command-1.6.9 74
diff --git a/games-arcade/penguin-command/files/digest-penguin-command-1.6.9 b/games-arcade/penguin-command/files/digest-penguin-command-1.6.9
new file mode 100644
index 000000000000..1227824c20e0
--- /dev/null
+++ b/games-arcade/penguin-command/files/digest-penguin-command-1.6.9
@@ -0,0 +1 @@
+MD5 2280971eb5cf3a1e26446e30d3f04ecb penguin-command-1.6.9.tar.gz 1182053
diff --git a/games-arcade/penguin-command/penguin-command-1.6.9.ebuild b/games-arcade/penguin-command/penguin-command-1.6.9.ebuild
new file mode 100644
index 000000000000..20438163540c
--- /dev/null
+++ b/games-arcade/penguin-command/penguin-command-1.6.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/penguin-command/penguin-command-1.6.9.ebuild,v 1.1 2005/04/29 22:50:01 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A clone of the classic Missile Command Game"
+HOMEPAGE="http://www.linux-games.com/penguin-command/"
+SRC_URI="mirror://sourceforge/penguin-command/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="nls"
+
+DEPEND="media-libs/libpng
+ media-libs/jpeg
+ >=media-libs/libsdl-1.1.5
+ media-libs/sdl-mixer"
+
+#src_unpack() {
+# unpack ${A}
+# cd "${S}"
+# sed -i 's:-DUSE_SOUND::' configure
+#}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ChangeLog README NEWS AUTHORS
+ if use nls ; then
+ dodir /usr/share/man/ja/man6
+ mv "${D}"/usr/share/man/man6/penguin-command.ja.6 "${D}"/usr/share/man/ja/man6/penguin-command.6
+ else
+ rm -f "${D}"/usr/share/man/man6/*.ja.*
+ fi
+ newicon data/gfx/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} ${PN} ${PN}.xpm
+ prepgamesdirs
+}