summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-27 07:22:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-27 07:22:45 +0000
commitb95ffb338c2b07913dfa070bb82833793561ea32 (patch)
tree40e95c1f2ddbf365795d024875025b6abd5f2be3 /games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild
parentExplicitly disable building dotnet grades. Thanks to Brian Danilko <brian@lik... (diff)
downloadhistorical-b95ffb338c2b07913dfa070bb82833793561ea32.tar.gz
historical-b95ffb338c2b07913dfa070bb82833793561ea32.tar.bz2
historical-b95ffb338c2b07913dfa070bb82833793561ea32.zip
version bump
Package-Manager: portage-2.1_pre7-r1
Diffstat (limited to 'games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild')
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild
new file mode 100644
index 000000000000..f0f7616f63e4
--- /dev/null
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild,v 1.1 2006/03/27 07:22:45 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="2d platform jump'n'run game"
+HOMEPAGE="http://www.mainreactor.net/holotzcastle/en/index_en.html"
+SRC_URI="http://www.mainreactor.net/holotzcastle/download/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-image"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake -C JLib CPU_OPTS="${CXXFLAGS}" || die "emake failed"
+ emake -C src CPU_OPTS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dogamesbin holotz-castle holotz-castle-editor || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}/game
+ doins -r HCedHome/* res/* || die "doins failed"
+ dodoc MANUAL*.txt
+ doman doc/*.6
+ prepgamesdirs
+}