summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-09 00:39:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-09 00:39:12 +0000
commitb72341eab645f4539844b1f09ad4c176347c0cc9 (patch)
tree7d694e6d3656637af35b260e29dcb31ca530d56f /games-action
parentremoved silly binutils dependency for hardened now that they've cecided to go... (diff)
downloadhistorical-b72341eab645f4539844b1f09ad4c176347c0cc9.tar.gz
historical-b72341eab645f4539844b1f09ad4c176347c0cc9.tar.bz2
historical-b72341eab645f4539844b1f09ad4c176347c0cc9.zip
rev bump for dedicated use flag support (bug #53079)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bzflag/ChangeLog9
-rw-r--r--games-action/bzflag/Manifest6
-rw-r--r--games-action/bzflag/bzflag-1.10.6.20040515-r1.ebuild48
-rw-r--r--games-action/bzflag/files/digest-bzflag-1.10.6.20040515-r11
4 files changed, 61 insertions, 3 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index 211c43ad291f..1d3aa401fe82 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-action/bzflag
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.10 2004/06/03 07:49:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.11 2004/06/09 00:39:12 mr_bones_ Exp $
+
+*bzflag-1.10.6.20040515-r1 (08 Jun 2004)
+
+ 08 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ bzflag-1.10.6.20040515-r1.ebuild:
+ rev bump for dedicated use flag support (bug #53079)
+ patch from Thomas R. Sibley
03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> bzflag-1.10.4.ebuild:
sed in unpack; fix use invocation; tidy
diff --git a/games-action/bzflag/Manifest b/games-action/bzflag/Manifest
index 98ff9ef21835..2a3e96b58909 100644
--- a/games-action/bzflag/Manifest
+++ b/games-action/bzflag/Manifest
@@ -1,8 +1,10 @@
-MD5 1514ca0b3ea3cb50b837f654a4b17326 ChangeLog 3025
+MD5 8b250a385362056d9c47e8a66a2f1bb5 ChangeLog 3244
MD5 58b1d46eb5b3f4db81baa736785e6cb8 bzflag-1.10.2.ebuild 840
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 3f74add3f022492259c18344fea5f5bf bzflag-1.10.4.ebuild 990
-MD5 4b213d71d53afa30209f1a35609c379d bzflag-1.10.6.20040515.ebuild 864
+MD5 bec613b3a41f6e7f695ca4ce9d34c8b9 bzflag-1.10.6.20040515.ebuild 863
+MD5 5be7a1afe9a31b5f0f440c30718c9e98 bzflag-1.10.6.20040515-r1.ebuild 1105
+MD5 68db64ca15f757b231109596d0e9bb0f files/digest-bzflag-1.10.6.20040515-r1 76
MD5 ef0f58d8eaa9ff60b2d3c2a31f9dc8d8 files/digest-bzflag-1.10.2 75
MD5 6fadc41f4074e508579a3a7ba2a4187d files/digest-bzflag-1.10.4 76
MD5 68db64ca15f757b231109596d0e9bb0f files/digest-bzflag-1.10.6.20040515 76
diff --git a/games-action/bzflag/bzflag-1.10.6.20040515-r1.ebuild b/games-action/bzflag/bzflag-1.10.6.20040515-r1.ebuild
new file mode 100644
index 000000000000..a1613e1a1f91
--- /dev/null
+++ b/games-action/bzflag/bzflag-1.10.6.20040515-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-1.10.6.20040515-r1.ebuild,v 1.1 2004/06/09 00:39:12 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="OpenGL accelerated 3d tank combat simulator game"
+HOMEPAGE="http://www.BZFlag.org/"
+SRC_URI="mirror://sourceforge/bzflag/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc amd64"
+IUSE="dedicated"
+
+RDEPEND="virtual/glibc
+ !dedicated? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:^CFLAGS=.*::' \
+ -e 's:^CXXFLAGS=.*::' \
+ -e 's:-mcpu=$host_cpu::' \
+ configure \
+ || die "sed failed"
+}
+
+src_compile() {
+ if use dedicated ; then
+ ewarn
+ ewarn "You are building a servers-only copy of BZFlag."
+ ewarn
+ egamesconf --disable-client || die
+ else
+ egamesconf || die
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README.UNIX TODO README ChangeLog BUGS PORTING
+ prepgamesdirs
+}
diff --git a/games-action/bzflag/files/digest-bzflag-1.10.6.20040515-r1 b/games-action/bzflag/files/digest-bzflag-1.10.6.20040515-r1
new file mode 100644
index 000000000000..afa15c9e1713
--- /dev/null
+++ b/games-action/bzflag/files/digest-bzflag-1.10.6.20040515-r1
@@ -0,0 +1 @@
+MD5 8e3e5fbef3cfa21079eb06269e6b3d8b bzflag-1.10.6.20040515.tar.bz2 3931553