summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-03-06 03:45:10 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-03-06 03:45:10 +0000
commit4f183cc390c7fb7704e1ed3573dfc2cdd62ead95 (patch)
tree65e09a7345ab8c2a06364bafef5f3a9db70ad48d /games-action
parentFixing quoting. (diff)
downloadhistorical-4f183cc390c7fb7704e1ed3573dfc2cdd62ead95.tar.gz
historical-4f183cc390c7fb7704e1ed3573dfc2cdd62ead95.tar.bz2
historical-4f183cc390c7fb7704e1ed3573dfc2cdd62ead95.zip
Stable on ppc/x86 and removing older versions.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'games-action')
-rw-r--r--games-action/xshipwars/ChangeLog9
-rw-r--r--games-action/xshipwars/files/xshipwars-1.34.0-gcc3.patch39
-rw-r--r--games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch31
-rw-r--r--games-action/xshipwars/xshipwars-1.34.0.ebuild87
-rw-r--r--games-action/xshipwars/xshipwars-2.5.5.ebuild6
5 files changed, 10 insertions, 162 deletions
diff --git a/games-action/xshipwars/ChangeLog b/games-action/xshipwars/ChangeLog
index eaf764d146b2..9ddfd837de97 100644
--- a/games-action/xshipwars/ChangeLog
+++ b/games-action/xshipwars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/xshipwars
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/ChangeLog,v 1.18 2007/07/06 06:24:53 tupone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/ChangeLog,v 1.19 2008/03/06 03:45:10 wolf31o2 Exp $
+
+ 06 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org>
+ -files/xshipwars-1.34.0-gcc3.patch, -files/xshipwars-1.34.0-gcc33.patch,
+ -xshipwars-1.34.0.ebuild, xshipwars-2.5.5.ebuild:
+ Stable on ppc/x86 and removing older versions.
06 Jul 2007; Tupone Alfredo <tupone@gentoo.org>
files/xshipwars-2.5.5-build.patch, xshipwars-2.5.5.ebuild:
diff --git a/games-action/xshipwars/files/xshipwars-1.34.0-gcc3.patch b/games-action/xshipwars/files/xshipwars-1.34.0-gcc3.patch
deleted file mode 100644
index f0dc567de4b5..000000000000
--- a/games-action/xshipwars/files/xshipwars-1.34.0-gcc3.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -uNr ../xsw-1.34.0.old/include/string.h ./include/string.h
---- ../xsw-1.34.0.old/include/string.h 2001-07-26 10:24:24.000000000 +0200
-+++ ./include/string.h 2002-11-30 17:59:35.000000000 +0100
-@@ -24,7 +24,7 @@
- extern int strcasecmp(const char *s1, const char *s2);
- #endif
- extern const char *strseekblank(const char *s);
--extern char *strcasestr(const char *haystack, const char *needle);
-+/* extern char *strcasestr(const char *haystack, const char *needle); */
- extern int strpfx(const char *str, const char *pfx);
- extern int strcasepfx(const char *str, const char *pfx);
- extern void strtoupper(char *s);
-diff -uNr ../xsw-1.34.0.old/include/xsw_ctype.h ./include/xsw_ctype.h
---- ../xsw-1.34.0.old/include/xsw_ctype.h 2001-07-26 10:26:38.000000000 +0200
-+++ ./include/xsw_ctype.h 2002-11-30 18:00:42.000000000 +0100
-@@ -4,10 +4,11 @@
- #if !defined(__FreeBSD__) && !defined(__NetBSD__)
- # if defined(__cplusplus) || defined(c_plusplus)
-
--#ifndef isblank
-+/*#ifndef isblank
- //extern bool isblank(char c);
- extern bool isblank(int c);
- #endif
-+*/
-
- #else
-
---- ./include/xsw_ctype.h.orig 2002-12-01 12:39:31.000000000 -0500
-+++ ./include/xsw_ctype.h 2002-12-01 12:39:44.000000000 -0500
-@@ -6,7 +6,7 @@
-
- #ifndef isblank
- //extern bool isblank(char c);
--extern bool isblank(int c);
-+extern int isblank(int c);
- #endif
-
- #else
diff --git a/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch b/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch
deleted file mode 100644
index f64de08f4d2a..000000000000
--- a/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Work around a gcc-3.3.x bug where redefining prototypes with different
-__THROW / attribute(nonnull) markings throws an error:
-
-string.cpp:31: error: declaration of `char* strcasestr(const char*, const char*)' throws different exceptions
-../include/string.h:46: error: than previous declaration `char* strcasestr(const char*, const char*) throw ()'
-
-basically we just use the glibc strcasestr() instead of the internal one.
-
-http://bugs.gentoo.org/show_bug.cgi?id=85780
-
---- global/string.cpp
-+++ global/string.cpp
-@@ -37,3 +37,5 @@
- #endif
-+#ifndef _GNU_SOURCE
- char *strcasestr(const char *haystack, const char *needle);
-+#endif
- int strpfx(const char *s, const char *pfx);
-@@ -221,3 +224,4 @@
- */
-+#ifndef _GNU_SOURCE
- char *strcasestr(const char *haystack, const char *needle)
- {
-@@ -274,6 +277,7 @@
-
- return(NULL);
- }
-+#endif
-
- /*
- * Checks if string pfx is a prefix of string s.
diff --git a/games-action/xshipwars/xshipwars-1.34.0.ebuild b/games-action/xshipwars/xshipwars-1.34.0.ebuild
deleted file mode 100644
index b4fcb7d29c5c..000000000000
--- a/games-action/xshipwars/xshipwars-1.34.0.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-1.34.0.ebuild,v 1.16 2006/12/01 20:14:29 wolf31o2 Exp $
-
-inherit toolchain-funcs eutils games
-
-MY_P=xsw-${PV}
-DESCRIPTION="massively multi-player, ultra graphical, space-oriented gaming system designed exclusively for network play"
-HOMEPAGE="http://wolfpack.twu.net/ShipWars/XShipWars/"
-SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${MY_P}.tar.bz2
- ftp://wolfpack.twu.net/users/wolfpack/xswdata-1.33d.tar.bz2
- ftp://wolfpack.twu.net/users/wolfpack/stimages1.7.tar.bz2
- ftp://wolfpack.twu.net/users/wolfpack/babylon5images1.1.tar.bz2
- ftp://wolfpack.twu.net/users/wolfpack/stsounds1.4.tgz"
-
-LICENSE="GPL-2 xshipwars"
-SLOT="0"
-KEYWORDS="ppc x86"
-IUSE=""
-
-RDEPEND="x11-libs/libXpm
- >=media-sound/esound-0.2.23"
-DEPEND="${RDEPEND}
- x11-proto/xextproto"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.bz2
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc33.patch
-}
-
-src_compile() {
- local makefile
-
- ./configure.client Linux --prefix=/usr || die
- ./configure.monitor Linux --prefix=/usr || die
- ./configure.server Linux --prefix=${GAMES_PREFIX} || die
- ./configure.unvedit Linux --prefix=/usr || die
-
- [ $(gcc-major-version) == 3 ] && epatch ${FILESDIR}/${P}-gcc3.patch
-
- for makefile in Makefile.* ; do
- make \
- -f ${makefile} \
- CPPFLAGS="-D__cplusplus -Dc_plusplus ${CFLAGS}" \
- all || die
- done
-}
-
-src_install() {
- make -f Makefile.client PREFIX=${D}/usr install || die
- make -f Makefile.monitor PREFIX=${D}/usr install || die
- make -f Makefile.server PREFIX=${D}/${GAMES_PREFIX} install || die
- make -f Makefile.unvedit PREFIX=${D}/usr install || die
-
- dodir ${GAMES_DATADIR}/${PN}
- tar -jxC ${D}/${GAMES_DATADIR}/${PN} -f ${DISTDIR}/xswdata-1.33d.tar.bz2
- tar -jxC ${D}/${GAMES_DATADIR}/${PN} -f ${DISTDIR}/stimages1.7.tar.bz2
- tar -jxC ${D}/${GAMES_DATADIR}/${PN} -f ${DISTDIR}/babylon5images1.1.tar.bz2
- tar -zxC ${D}/${GAMES_DATADIR}/${PN} -f ${DISTDIR}/stsounds1.4.tgz
-
- # put the binaries in the right place
- dodir ${GAMES_BINDIR}
- mv ${D}/usr/games/{unvedit,xsw,monitor} ${D}/${GAMES_BINDIR}/
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- einfo "Before playing, you should get a copy of the installed "
- einfo "global XShipWars client configuration file and copy it to "
- einfo "your home directory: "
- echo
- einfo "# mkdir ~/.shipwars/"
- einfo "# cd /usr/share/games/xshipwars/etc/ "
- einfo "# cp xshipwarsrc ~/.shipwars/xshipwarsrc "
- einfo "# cp universes ~/.shipwars/universes "
- echo
- einfo "You will probably need to edit the xshipwarsrc to fit your needs."
- echo
- einfo "Then type 'xsw &' to start the game"
- echo
-}
diff --git a/games-action/xshipwars/xshipwars-2.5.5.ebuild b/games-action/xshipwars/xshipwars-2.5.5.ebuild
index a2f894ce6ad2..28280971c4fc 100644
--- a/games-action/xshipwars/xshipwars-2.5.5.ebuild
+++ b/games-action/xshipwars/xshipwars-2.5.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-2.5.5.ebuild,v 1.4 2007/07/06 06:24:53 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-2.5.5.ebuild,v 1.5 2008/03/06 03:45:10 wolf31o2 Exp $
inherit toolchain-funcs eutils games
@@ -14,7 +14,7 @@ SRC_URI="http://wolfpack.twu.net/users/wolfpack/${MY_P}.tar.bz2
LICENSE="GPL-2 xshipwars"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ppc x86"
IUSE="joystick yiff esd debug"
RDEPEND="x11-libs/libXpm