summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-03 05:56:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-03 05:56:40 +0000
commit2d81c727a51d12f88ff30c12c4ab99172091a877 (patch)
tree740371bdbadae7ae12be6c9b7cbcd23b56c16a6c /games-action
parentversion bump (bug #52236) (diff)
downloadhistorical-2d81c727a51d12f88ff30c12c4ab99172091a877.tar.gz
historical-2d81c727a51d12f88ff30c12c4ab99172091a877.tar.bz2
historical-2d81c727a51d12f88ff30c12c4ab99172091a877.zip
die backticks
Diffstat (limited to 'games-action')
-rw-r--r--games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild4
-rw-r--r--games-action/xpilot/ChangeLog5
-rw-r--r--games-action/xpilot/xpilot-4.5.4.ebuild9
-rw-r--r--games-action/xshipwars/ChangeLog6
-rw-r--r--games-action/xshipwars/xshipwars-1.34.0.ebuild4
5 files changed, 18 insertions, 10 deletions
diff --git a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
index 47abfa074573..5aa3a999104b 100644
--- a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
+++ b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild,v 1.1 2004/03/09 18:42:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild,v 1.2 2004/06/03 05:56:40 mr_bones_ Exp $
inherit eutils games
@@ -43,7 +43,7 @@ src_unpack() {
-e "s:TBTHOME \"/config.xml:\"${GAMES_SYSCONFDIR}/tbt/config.xml:g" \
global.h || die "sed global,h failed"
- for f in `find ${S} -type f`
+ for f in $(find ${S} -type f)
do
edos2unix ${f}
done
diff --git a/games-action/xpilot/ChangeLog b/games-action/xpilot/ChangeLog
index 42b4a3272746..a3ade6e2f54c 100644
--- a/games-action/xpilot/ChangeLog
+++ b/games-action/xpilot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/xpilot
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.3 2004/03/31 03:33:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.4 2004/06/03 05:52:47 mr_bones_ Exp $
+
+ 02 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> xpilot-4.5.4.ebuild:
+ die backticks
30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> xpilot-4.5.4.ebuild:
sed in unpack; IUSE; virtual/x11
diff --git a/games-action/xpilot/xpilot-4.5.4.ebuild b/games-action/xpilot/xpilot-4.5.4.ebuild
index 75adc91134fa..516070f85196 100644
--- a/games-action/xpilot/xpilot-4.5.4.ebuild
+++ b/games-action/xpilot/xpilot-4.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.4.ebuild,v 1.3 2004/03/31 03:33:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.4.ebuild,v 1.4 2004/06/03 05:52:47 mr_bones_ Exp $
DESCRIPTION="A multi-player 2D client/server space game"
HOMEPAGE="http://www.xpilot.org/"
@@ -31,9 +31,10 @@ src_compile() {
xmkmf || die "xmkmf Makefile creation failed"
make Makefiles || die "Makefiles problem"
local f
- for f in `find . -type f -regex .*Makefile`; do
- sed -i -e "s:CDEBUGFLAGS = -O:CDEBUGFLAGS = ${CFLAGS}:" $f ||
- die "sed $f failed"
+ for f in $(find . -type f -regex .*Makefile); do
+ sed -i \
+ -e "s:CDEBUGFLAGS = -O:CDEBUGFLAGS = ${CFLAGS}:" $f \
+ || die "sed $f failed"
done
make includes || die "includes problem"
make depend || die "depend problem"
diff --git a/games-action/xshipwars/ChangeLog b/games-action/xshipwars/ChangeLog
index 76ae078c1a11..66a88ab3ab4c 100644
--- a/games-action/xshipwars/ChangeLog
+++ b/games-action/xshipwars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/xshipwars
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/ChangeLog,v 1.4 2004/03/31 03:35:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/ChangeLog,v 1.5 2004/06/03 05:49:31 mr_bones_ Exp $
+
+ 02 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ xshipwars-1.34.0.ebuild:
+ die backticks
30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
xshipwars-1.34.0.ebuild:
diff --git a/games-action/xshipwars/xshipwars-1.34.0.ebuild b/games-action/xshipwars/xshipwars-1.34.0.ebuild
index bf3226f22cda..baf1b220bd7f 100644
--- a/games-action/xshipwars/xshipwars-1.34.0.ebuild
+++ b/games-action/xshipwars/xshipwars-1.34.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-1.34.0.ebuild,v 1.5 2004/03/31 03:35:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-1.34.0.ebuild,v 1.6 2004/06/03 05:49:31 mr_bones_ Exp $
inherit gcc eutils games
@@ -33,7 +33,7 @@ src_compile() {
./configure.server Linux --prefix=${GAMES_PREFIX} || die
./configure.unvedit Linux --prefix=/usr || die
- [ `gcc-major-version` == 3 ] && epatch ${FILESDIR}/${P}-gcc3.patch
+ [ $(gcc-major-version) == 3 ] && epatch ${FILESDIR}/${P}-gcc3.patch
for makefile in Makefile.* ; do
make \