summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-30 04:37:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-30 04:37:47 +0000
commit00c5a3a1587650cc95cf49ff3c4b7784cb452478 (patch)
treecf043943746e15b1f680bbd380abdf1f329703fa /games-action
parentinitial import (diff)
downloadhistorical-00c5a3a1587650cc95cf49ff3c4b7784cb452478.tar.gz
historical-00c5a3a1587650cc95cf49ff3c4b7784cb452478.tar.bz2
historical-00c5a3a1587650cc95cf49ff3c4b7784cb452478.zip
Fix CFLAGS breakage and sync some mismatched prototypes.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-action')
-rw-r--r--games-action/gltron/ChangeLog9
-rw-r--r--games-action/gltron/Manifest12
-rw-r--r--games-action/gltron/files/gltron-0.70-configure.patch24
-rw-r--r--games-action/gltron/files/gltron-0.70-prototypes.patch24
-rw-r--r--games-action/gltron/gltron-0.70.ebuild22
5 files changed, 82 insertions, 9 deletions
diff --git a/games-action/gltron/ChangeLog b/games-action/gltron/ChangeLog
index 997cd466745f..2c110af660d2 100644
--- a/games-action/gltron/ChangeLog
+++ b/games-action/gltron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/gltron
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.8 2005/05/31 16:16:32 cryos Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.9 2005/07/30 04:37:47 vapier Exp $
+
+ 30 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gltron-0.70-configure.patch, +files/gltron-0.70-prototypes.patch,
+ gltron-0.70.ebuild:
+ Fix CFLAGS breakage and sync some mismatched prototypes.
31 May 2005; Marcus D. Hanwell <marcus@gentoo.org> gltron-0.70.ebuild:
Stable on amd64.
diff --git a/games-action/gltron/Manifest b/games-action/gltron/Manifest
index d64becadffda..810fcd9fda9d 100644
--- a/games-action/gltron/Manifest
+++ b/games-action/gltron/Manifest
@@ -1,14 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 d129a128e2bf47e99838dec084e05b5e ChangeLog 2073
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 9c560e56d6af2e49b9efdc50635985a6 gltron-0.70.ebuild 708
+MD5 a6caa5544ca78cc9443eeac0f7ffd592 gltron-0.70.ebuild 1065
+MD5 fbca6004fbfc807c363872f8d2d262dc ChangeLog 2281
MD5 e609d589da3c307eeae20a7b515cb920 files/digest-gltron-0.70 71
+MD5 9cd844f561d537df49a35fac21d5b51c files/gltron-0.70-configure.patch 618
+MD5 744c0f80394f8713aebdf7038044570e files/gltron-0.70-prototypes.patch 625
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCnI4untT9W3vfTuoRAv1zAJ9FTvN68ysu9kbz4y761id2swPFwgCgnDBt
-m2OjlsYn9FypGl4MVFfpqeA=
-=cpEV
+iD8DBQFC6wQrgIKl8Uu19MoRAinLAJ9Nt08lv9hdHeQgqztkuk/I6eL/AACfXcy0
+ZfeBuKeCE9EDqEq6jEXJftU=
+=HS/b
-----END PGP SIGNATURE-----
diff --git a/games-action/gltron/files/gltron-0.70-configure.patch b/games-action/gltron/files/gltron-0.70-configure.patch
new file mode 100644
index 000000000000..91414b3956ec
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-configure.patch
@@ -0,0 +1,24 @@
+configure.in is written poorly so it just stomps all over CFLAGS
+
+--- configure
++++ configure
+@@ -2805,7 +2805,7 @@
+ RANLIB="$ac_cv_prog_RANLIB"
+ fi
+
+-CFLAGS="-DSEPARATOR=\"'/'\""
++CFLAGS="$CFLAGS -DSEPARATOR=\"'/'\""
+
+ # Check whether --enable-warn or --disable-warn was given.
+ if test "${enable_warn+set}" = set; then
+@@ -2852,10 +2852,6 @@
+ else
+ enable_optimize=s
+ fi;
+-if test "x$enable_optimize" ; then
+- CFLAGS="$CFLAGS -O$enable_optimize"
+- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
+-fi
+
+ # Check whether --with-sdl-prefix or --without-sdl-prefix was given.
+ if test "${with_sdl_prefix+set}" = set; then
diff --git a/games-action/gltron/files/gltron-0.70-prototypes.patch b/games-action/gltron/files/gltron-0.70-prototypes.patch
new file mode 100644
index 000000000000..d697f1ad59ac
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-prototypes.patch
@@ -0,0 +1,24 @@
+scripting.h declares these params as const so make sure they're the same.
+
+--- nebu/scripting/scripting.c
++++ nebu/scripting/scripting.c
+@@ -169,16 +169,16 @@
+ return status;
+ }
+
+-void scripting_RunFile(char *name) {
++void scripting_RunFile(const char *name) {
+ lua_dofile(L, name);
+ }
+
+-void scripting_Run(char *command) {
++void scripting_Run(const char *command) {
+ /* fprintf(stderr, "[command] %s\n", command); */
+ lua_dostring(L, command);
+ }
+
+-void scripting_RunFormat(char *format, ... ) {
++void scripting_RunFormat(const char *format, ... ) {
+ char buf[4096];
+ va_list ap;
+ va_start(ap, format);
diff --git a/games-action/gltron/gltron-0.70.ebuild b/games-action/gltron/gltron-0.70.ebuild
index 0daa48252401..c8ddae925921 100644
--- a/games-action/gltron/gltron-0.70.ebuild
+++ b/games-action/gltron/gltron-0.70.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70.ebuild,v 1.5 2005/05/31 16:16:32 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70.ebuild,v 1.6 2005/07/30 04:37:47 vapier Exp $
-inherit games
+inherit eutils games
DESCRIPTION="3d tron, just like the movie"
HOMEPAGE="http://gltron.sourceforge.net/"
@@ -21,6 +21,24 @@ DEPEND="virtual/x11
media-libs/sdl-mixer
media-libs/sdl-sound"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-prototypes.patch
+}
+
+src_compile() {
+ # warn/debug/profile just modify CFLAGS, they aren't
+ # real options, so don't utilize USE flags here
+ egamesconf \
+ --disable-warn \
+ --disable-debug \
+ --disable-profile \
+ || die
+ emake || die
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc ChangeLog README