summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-04 02:27:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-04 02:27:07 +0000
commit02ede9432251c4fc41d41684137813e5b24d7fe5 (patch)
tree2bc493175326e4d85fc4fb4d590438a07a14ff64 /games-action/transcend
parent103482 instead of 103402, fixed... (diff)
downloadhistorical-02ede9432251c4fc41d41684137813e5b24d7fe5.tar.gz
historical-02ede9432251c4fc41d41684137813e5b24d7fe5.tar.bz2
historical-02ede9432251c4fc41d41684137813e5b24d7fe5.zip
version bump
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-action/transcend')
-rw-r--r--games-action/transcend/ChangeLog8
-rw-r--r--games-action/transcend/Manifest4
-rw-r--r--games-action/transcend/files/digest-transcend-0.31
-rw-r--r--games-action/transcend/transcend-0.3.ebuild58
4 files changed, 69 insertions, 2 deletions
diff --git a/games-action/transcend/ChangeLog b/games-action/transcend/ChangeLog
index 45cffa48cec1..594bb4ad528a 100644
--- a/games-action/transcend/ChangeLog
+++ b/games-action/transcend/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/transcend
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.2 2005/02/22 12:21:54 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.3 2005/09/04 02:27:07 mr_bones_ Exp $
+
+*transcend-0.3 (04 Sep 2005)
+
+ 04 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +transcend-0.3.ebuild:
+ version bump
22 Feb 2005; David Holm <dholm@gentoo.org> transcend-0.2.ebuild:
Added to ~ppc.
diff --git a/games-action/transcend/Manifest b/games-action/transcend/Manifest
index 449ed664e6e4..6419bbd2b872 100644
--- a/games-action/transcend/Manifest
+++ b/games-action/transcend/Manifest
@@ -1,4 +1,6 @@
-MD5 fc9466b332d2ac974440400f6ebbc6d7 ChangeLog 457
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 5c097fdbd6f5bddf41e08eb078e28ff0 transcend-0.3.ebuild 1273
MD5 a8bf3103fbaf860d6c49efbc359d4f3b transcend-0.2.ebuild 1333
+MD5 763728262c768a9257ff6d384c820857 ChangeLog 587
+MD5 87d8b99a6ac1e0121cf90143601d8aa0 files/digest-transcend-0.3 77
MD5 bc06eaad665cd403a40c948ab56bb7c1 files/digest-transcend-0.2 83
diff --git a/games-action/transcend/files/digest-transcend-0.3 b/games-action/transcend/files/digest-transcend-0.3
new file mode 100644
index 000000000000..3fefe0626136
--- /dev/null
+++ b/games-action/transcend/files/digest-transcend-0.3
@@ -0,0 +1 @@
+MD5 0d96a66037a738c0546c47916a281cd6 Transcend_0.3_UnixSource.tar.gz 1847261
diff --git a/games-action/transcend/transcend-0.3.ebuild b/games-action/transcend/transcend-0.3.ebuild
new file mode 100644
index 000000000000..a5f80df7a50b
--- /dev/null
+++ b/games-action/transcend/transcend-0.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/transcend-0.3.ebuild,v 1.1 2005/09/04 02:27:07 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="retro-style, abstract, 2D shooter"
+HOMEPAGE="http://transcend.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/Transcend_${PV}_UnixSource.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/opengl
+ virtual/glu
+ virtual/glut"
+
+S=${WORKDIR}/Transcend_${PV}_UnixSource/Transcend
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ chmod a+x portaudio/configure
+ rm -f game/Makefile
+ cat \
+ Makefile.GnuLinuxX86 \
+ Makefile.common \
+ Makefile.minorGems \
+ game/Makefile.all \
+ Makefile.minorGems_targets \
+ > game/Makefile
+ sed -i \
+ -e "s:\"levels\":\"${GAMES_DATADIR}/${PN}/levels\":" \
+ game/LevelDirectoryManager.cpp \
+ game/game.cpp \
+ || die "sed failed"
+}
+
+src_compile() {
+ cd portaudio
+ egamesconf || die
+ emake
+ cd ../game
+ emake || die
+ cd ..
+ cp game/Transcend ${PN} || die "cp failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r levels/ || die "doins failed"
+ dodoc doc/how_to_*.txt
+ prepgamesdirs
+}