summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/stepmania/stepmania-20030705.ebuild
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/stepmania/stepmania-20030705.ebuild')
-rw-r--r--games-action/stepmania/stepmania-20030705.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-action/stepmania/stepmania-20030705.ebuild b/games-action/stepmania/stepmania-20030705.ebuild
new file mode 100644
index 000000000000..58ce210a75f9
--- /dev/null
+++ b/games-action/stepmania/stepmania-20030705.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/stepmania/stepmania-20030705.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+MY_PV="cvs-5Jul03"
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An advanced DDR simulator"
+HOMEPAGE="http://www.stepmania.com/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/libmad
+ media-libs/libogg
+ media-libs/libvorbis"
+
+src_install() {
+ dogamesbin ${S}/src/stepmania
+ cp -r ${S}/Announcers ${S}/BGAnimations ${S}/CDTitles ${S}/Cache \
+ ${S}/Characters ${S}/Courses ${S}/Data ${S}/Docs ${S}/NoteSkins \
+ ${S}/RandomMovies ${S}/Songs ${S}/Themes ${S}/Utils \
+ ${S}/Visualizations ${D}/usr/games/stepmania/
+}