summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/raptor2/raptor2-1.0.0.ebuild
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/raptor2/raptor2-1.0.0.ebuild')
-rw-r--r--games-action/raptor2/raptor2-1.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-action/raptor2/raptor2-1.0.0.ebuild b/games-action/raptor2/raptor2-1.0.0.ebuild
new file mode 100644
index 000000000000..844ad55b5155
--- /dev/null
+++ b/games-action/raptor2/raptor2-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/raptor2/raptor2-1.0.0.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit eutils games
+
+MY_P="raptor-${PV}"
+DESCRIPTION="space shoot-em-up game"
+SRC_URI="mirror://sourceforge/raptorv2/${MY_P}.tar.gz"
+HOMEPAGE="http://raptorv2.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="oggvorbis nls"
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=">=media-libs/allegro-4.0.0
+ =media-libs/dumb-0.9.1"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ epatch ${FILESDIR}/${PV}-chdir.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}/:" \
+ src/raptor.cpp || die "sed src/raptor.cpp failed"
+}
+
+src_compile() {
+ egamesconf || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ dogamesbin src/raptor
+
+ insinto ${GAMES_DATADIR}/${PN}/data
+ doins data/*
+
+ dodoc AUTHORS ChangeLog README NEWS
+
+ prepgamesdirs
+}