summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/moon-buggy/moon-buggy-0.5.53.ebuild
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/moon-buggy/moon-buggy-0.5.53.ebuild')
-rw-r--r--games-action/moon-buggy/moon-buggy-0.5.53.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-action/moon-buggy/moon-buggy-0.5.53.ebuild b/games-action/moon-buggy/moon-buggy-0.5.53.ebuild
new file mode 100644
index 000000000000..f71b3929eedc
--- /dev/null
+++ b/games-action/moon-buggy/moon-buggy-0.5.53.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/moon-buggy/moon-buggy-0.5.53.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A simple console game, where you drive a car across the moon's surface"
+HOMEPAGE="http://www.mathematik.uni-kl.de/~wwwstoch/voss/comp/moon-buggy.html"
+SRC_URI="http://www.mathematik.uni-kl.de/~wwwstoch/voss/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/ncurses-5*
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:$(DESTDIR)$(bindir)/moon-buggy -c:#$(DESTDIR)$(bindir)/moon-buggy -c:' \
+ Makefile.in || die "sed Makefile.in failed"
+}
+
+src_compile() {
+ egamesconf || die
+ emake || die
+}
+
+src_install() {
+ einstall bindir=${D}/${GAMES_BINDIR} || die
+ prepgamesdirs
+}