summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/maelstrom/maelstrom-3.0.6.ebuild
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/maelstrom/maelstrom-3.0.6.ebuild')
-rw-r--r--games-action/maelstrom/maelstrom-3.0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-action/maelstrom/maelstrom-3.0.6.ebuild b/games-action/maelstrom/maelstrom-3.0.6.ebuild
new file mode 100644
index 000000000000..035138f0da6e
--- /dev/null
+++ b/games-action/maelstrom/maelstrom-3.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit eutils
+
+MY_P=Maelstrom-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An asteroids battle game"
+SRC_URI="http://www.devolution.com/~slouken/Maelstrom/src/${MY_P}.tar.gz"
+HOMEPAGE="http://www.devolution.com/~slouken/Maelstrom/"
+
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=media-libs/libsdl-1.1.5
+ >=media-libs/sdl-net-1.2.2"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-security.patch
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog README TODO DIFFERENCES INTERESTING-COMBINATIONS
+}