summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-06-13 16:22:28 +0000
committerTristan Heaven <tristan@gentoo.org>2007-06-13 16:22:28 +0000
commitd1f5a6ef30c219a9a82f90444078ede24866c739 (patch)
tree242c08fc7793337c7192b350072bf65b438db0f6 /games-action/koth/koth-0.8.0.ebuild
parentalpha stable wrt #159269 (diff)
downloadhistorical-d1f5a6ef30c219a9a82f90444078ede24866c739.tar.gz
historical-d1f5a6ef30c219a9a82f90444078ede24866c739.tar.bz2
historical-d1f5a6ef30c219a9a82f90444078ede24866c739.zip
Install cfg into GAMES_SYSCONFDIR; compile fix for new libggi version
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'games-action/koth/koth-0.8.0.ebuild')
-rw-r--r--games-action/koth/koth-0.8.0.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/games-action/koth/koth-0.8.0.ebuild b/games-action/koth/koth-0.8.0.ebuild
index 0ebf7e264622..9297a2d1dfdf 100644
--- a/games-action/koth/koth-0.8.0.ebuild
+++ b/games-action/koth/koth-0.8.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation and Arcady Genkin <agenkin@thpoon.com>
+# Copyright 1999-2007 Gentoo Foundation and Arcady Genkin <agenkin@thpoon.com>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/koth/koth-0.8.0.ebuild,v 1.13 2005/06/15 17:31:31 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/koth/koth-0.8.0.ebuild,v 1.14 2007/06/13 16:22:28 nyhm Exp $
inherit eutils games
@@ -15,16 +15,23 @@ IUSE=""
DEPEND="media-libs/libggi"
-src_unpack(){
- unpack ${A}
- cd ${S}/src
- epatch ${FILESDIR}/koth-0.8.0-gcc-3.4.patch
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ sed -i 's:-g -O2::' configure \
+ || die "sed configure failed"
+ cd src
+ epatch "${FILESDIR}"/${P}-gcc-3.4.patch
+ sed -i "s:/etc/koth:${GAMES_SYSCONFDIR}:" cfgfile.h \
+ || die "sed cfgfile.h failed"
+ sed -i 's:(uint16):(uint16_t):' gfx.c gfx.h \
+ || die "sed gfx.c gfx.h failed"
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
- insinto /etc/koth
- doins src/koth.cfg
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_SYSCONFDIR}"
+ doins src/koth.cfg || die "doins failed"
dodoc AUTHORS ChangeLog NEWS README doc/*.txt
prepgamesdirs
}