summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-13 21:04:32 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-13 21:04:32 +0000
commitdffcac514fd28f27b5eacc0188a8c6489903ada2 (patch)
tree29d57052800e4d8df346e3c4dd4d1c9345bcf1c9 /games-action/geki2-KXL/geki2-KXL-2.0.3-r1.ebuild
parentfix version numbers that aren't needed anymore (diff)
downloadhistorical-dffcac514fd28f27b5eacc0188a8c6489903ada2.tar.gz
historical-dffcac514fd28f27b5eacc0188a8c6489903ada2.tar.bz2
historical-dffcac514fd28f27b5eacc0188a8c6489903ada2.zip
games.eclass support
Diffstat (limited to 'games-action/geki2-KXL/geki2-KXL-2.0.3-r1.ebuild')
-rw-r--r--games-action/geki2-KXL/geki2-KXL-2.0.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-action/geki2-KXL/geki2-KXL-2.0.3-r1.ebuild b/games-action/geki2-KXL/geki2-KXL-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..a696dc58e593
--- /dev/null
+++ b/games-action/geki2-KXL/geki2-KXL-2.0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/geki2-KXL/geki2-KXL-2.0.3-r1.ebuild,v 1.1 2003/11/13 21:04:32 vapier Exp $
+
+inherit games
+
+DESCRIPTION="2D length scroll shooting game"
+HOMEPAGE="http://kxl.hn.org/"
+SRC_URI="http://kxl.hn.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=dev-games/KXL-1.1.4"
+
+src_unpack() {
+ unpack ${A}
+ cp -rf ${S}{,.orig}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gentoo-paths.patch
+ aclocal || die "aclocal failed"
+ automake -a || die "automake failed"
+ autoconf || die "autoconf failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog COPYING README
+ prepgamesdirs
+}