summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-20 01:40:24 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-20 01:40:24 +0000
commit3e82e10584d5c10ce2c3136c16073bf22396b5c2 (patch)
tree574090fb23c870cee828c783a24453edc3ec2361 /games-action/chromium/files
parentold (diff)
downloadhistorical-3e82e10584d5c10ce2c3136c16073bf22396b5c2.tar.gz
historical-3e82e10584d5c10ce2c3136c16073bf22396b5c2.tar.bz2
historical-3e82e10584d5c10ce2c3136c16073bf22396b5c2.zip
DEPEND cleanup #33866 and build it nicer
Diffstat (limited to 'games-action/chromium/files')
-rw-r--r--games-action/chromium/files/0.9.12-gcc3-gentoo.patch11
-rw-r--r--games-action/chromium/files/0.9.12-proper-options.patch57
-rw-r--r--games-action/chromium/files/digest-chromium-0.9.12-r52
3 files changed, 70 insertions, 0 deletions
diff --git a/games-action/chromium/files/0.9.12-gcc3-gentoo.patch b/games-action/chromium/files/0.9.12-gcc3-gentoo.patch
new file mode 100644
index 000000000000..3e3e41095983
--- /dev/null
+++ b/games-action/chromium/files/0.9.12-gcc3-gentoo.patch
@@ -0,0 +1,11 @@
+diff -ur Chromium-0.9/src/NCString.cpp Chromium-0.9.m/src/NCString.cpp
+--- Chromium-0.9/src/NCString.cpp 2001-05-20 12:04:58.000000000 -0500
++++ Chromium-0.9.m/src/NCString.cpp 2002-07-25 22:57:03.000000000 -0500
+@@ -5,6 +5,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <limits.h>
++#include <stdarg.h>
+
+ /**
+ * ctor
diff --git a/games-action/chromium/files/0.9.12-proper-options.patch b/games-action/chromium/files/0.9.12-proper-options.patch
new file mode 100644
index 000000000000..75643b930c41
--- /dev/null
+++ b/games-action/chromium/files/0.9.12-proper-options.patch
@@ -0,0 +1,57 @@
+--- configure.orig 2003-11-19 19:33:19.947616192 -0500
++++ configure 2003-11-19 19:35:31.510615576 -0500
+@@ -7,10 +7,6 @@
+
+ ## Defaults
+ ###################################
+-ENABLE_SDL="yes"
+-ENABLE_SMPEG="yes"
+-ENABLE_VORBIS="no"
+-ENABLE_SETUP="yes"
+
+ ## Where do we look for stuff?
+ ###################################
+@@ -158,8 +154,8 @@
+ ## set up other config.mak variables
+ ######################################################################
+ GL_LIBS="-lglpng -lGL -lGLU -lm"
+-AL_LIBS="-L../support/openal/lib -lopenal -ldl"
+-AL_CFLAGS="-I../support/openal/linux/include -I../support/openal/include"
++AL_LIBS="-lopenal -ldl"
++AL_CFLAGS=""
+
+ ## write out config.mak
+ ######################################################################
+--- scripts/Makefile.all.orig 2003-11-19 19:41:22.502256736 -0500
++++ scripts/Makefile.all 2003-11-19 19:41:25.414813960 -0500
+@@ -1,5 +1,4 @@
+ SUPPORT_DIRS = \
+- ./support/openal/ \
+ ./support/glpng/src
+
+ CHROMIUM_DIRS = \
+--- scripts/Makefile.no-setup.orig 2003-11-19 19:41:22.502256736 -0500
++++ scripts/Makefile.no-setup 2003-11-19 19:41:25.414813960 -0500
+@@ -1,5 +1,4 @@
+ SUPPORT_DIRS = \
+- ./support/openal/ \
+ ./support/glpng/src
+
+ CHROMIUM_DIRS = \
+--- src-setup/Audio.cpp.orig 2003-11-19 20:03:23.237474464 -0500
++++ src-setup/Audio.cpp 2003-11-19 20:03:49.838430504 -0500
+@@ -71,7 +71,14 @@
+ if(!initialized)
+ {
+ fprintf(stderr, "starting OpenAL...");
++#ifdef OLD_OPENAL
+ context_id = alcCreateContext(NULL);
++#else
++ ALCdevice *dev;
++ dev = alcOpenDevice( NULL );
++ context_id = alcCreateContext(dev, NULL);
++ alcMakeContextCurrent(context_id);
++#endif
+ initialized = (bool)context_id;
+ fprintf(stderr, "done.\n");
+
diff --git a/games-action/chromium/files/digest-chromium-0.9.12-r5 b/games-action/chromium/files/digest-chromium-0.9.12-r5
new file mode 100644
index 000000000000..c31ca7413705
--- /dev/null
+++ b/games-action/chromium/files/digest-chromium-0.9.12-r5
@@ -0,0 +1,2 @@
+MD5 969883f2f20f10cd6cdb380582f130c4 chromium-src-0.9.12.tar.gz 640283
+MD5 173fdf76f1e4d7496142cd5662456a73 chromium-data-0.9.12.tar.gz 1111134