summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-10 11:38:17 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-10 11:38:17 +0000
commitdad1142a9a7f2ea3220838359d99486ae5425153 (patch)
treecd4469b7197bb6c4c72176eb900b7cbb0d77ec11 /eclass
parentRaise eudev dependency to -r2. (diff)
downloadhistorical-dad1142a9a7f2ea3220838359d99486ae5425153.tar.gz
historical-dad1142a9a7f2ea3220838359d99486ae5425153.tar.bz2
historical-dad1142a9a7f2ea3220838359d99486ae5425153.zip
Error out if "tests" package is installed. This is a common mistake and a source of file collisions.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/distutils-r1.eclass6
2 files changed, 10 insertions, 2 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index d9b560902175..9666cd046e62 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.666 2013/02/08 20:51:35 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.667 2013/02/10 11:38:17 mgorny Exp $
+
+ 10 Feb 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Error out if "tests" package is installed. This is a common mistake and a
+ source of file collisions.
08 Feb 2013; Michał Górny <mgorny@gentoo.org> vcs-snapshot.eclass:
Document the src_unpack() function. Requested in bug #456160.
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 27730f579244..043fe1b0c2da 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.48 2013/01/27 16:39:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.49 2013/02/10 11:38:17 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -367,6 +367,10 @@ distutils-r1_python_install() {
esetup.py install "${flags[@]}" --root="${root}" "${@}"
+ if [[ -d ${root}$(python_get_sitedir)/tests ]]; then
+ die "Package installs 'tests' package, file collisions likely."
+ fi
+
if [[ ! ${DISTUTILS_SINGLE_IMPL} ]]; then
_distutils-r1_rename_scripts "${root}"
_distutils-r1_merge_root "${root}" "${D}"