summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-10-09 08:41:41 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-10-09 08:41:41 +0000
commit6e929f4f86dcfbf46b7cd87340a7740778e7469d (patch)
tree4d7c016a415cceb3a448f2778db11d59d8b21b02 /eclass
parentunmasking wxGTK and wxPython 2.4.2 (diff)
downloadhistorical-6e929f4f86dcfbf46b7cd87340a7740778e7469d.tar.gz
historical-6e929f4f86dcfbf46b7cd87340a7740778e7469d.tar.bz2
historical-6e929f4f86dcfbf46b7cd87340a7740778e7469d.zip
adding hook to disable runtime compiling of pyc
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils.eclass6
-rw-r--r--eclass/python.eclass6
2 files changed, 10 insertions, 2 deletions
diff --git a/eclass/distutils.eclass b/eclass/distutils.eclass
index 3dc91edb7f72..72ec564c7e56 100644
--- a/eclass/distutils.eclass
+++ b/eclass/distutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.15 2003/10/02 23:14:17 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.16 2003/10/09 08:41:41 liquidx Exp $
#
# Author: Jon Nelson <jnelson@gentoo.org>
# Current Maintainer: Alastair Tse <liquidx@gentoo.org>
@@ -19,6 +19,8 @@
# PYTHON_SLOT_VERSION - for Zope support
# DOCS - additional DOCS
+inherit python
+
ECLASS=distutils
INHERITED="$INHERITED $ECLASS"
@@ -33,10 +35,12 @@ else
fi
distutils_src_compile() {
+ python_disable_pyc
${python} setup.py build "$@" || die "compilation failed"
}
distutils_src_install() {
+ python_disable_pyc
${python} setup.py install --root=${D} "$@" || die
dodoc CHANGELOG COPYRIGHT KNOWN_BUGS MAINTAINERS PKG-INFO
diff --git a/eclass/python.eclass b/eclass/python.eclass
index c90ad2469aac..49ded9e41f97 100644
--- a/eclass/python.eclass
+++ b/eclass/python.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.1 2003/10/08 14:07:38 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/python.eclass,v 1.2 2003/10/09 08:41:40 liquidx Exp $
#
# Author: Alastair Tse <liquidx@gentoo.org>
#
@@ -22,6 +22,10 @@ inherit alternatives
ECLASS="python"
INHERITED="$INHERITED $ECLASS"
+python_disable_pyc() {
+ PYTHON_DONTCOMPILE=1
+}
+
#
# name: python_version
# desc: run without arguments and it will export the version of python