summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-11 19:49:17 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-11 19:49:17 +0000
commit22ee6c5eb19f8a0f849389327b52d2b08ed6dec6 (patch)
tree890ad1b83100dec8af26ea4d4bef34a07c10c52f /eclass
parentupdated version that works (diff)
downloadhistorical-22ee6c5eb19f8a0f849389327b52d2b08ed6dec6.tar.gz
historical-22ee6c5eb19f8a0f849389327b52d2b08ed6dec6.tar.bz2
historical-22ee6c5eb19f8a0f849389327b52d2b08ed6dec6.zip
make makefile patch conditional on the makefile existing :-) (it was failing for those of the
languages that don't have the makefile rpegenerated)
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde-i18n.eclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/eclass/kde-i18n.eclass b/eclass/kde-i18n.eclass
index d2765c7a68fb..f5ee1f8875f6 100644
--- a/eclass/kde-i18n.eclass
+++ b/eclass/kde-i18n.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.eclass,v 1.15 2002/04/20 09:55:11 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.eclass,v 1.16 2002/06/11 19:49:17 danarmak Exp $
inherit kde kde.org
ECLASS=kde-i18n
@@ -18,8 +18,10 @@ SRC_URI="$SRC_URI http://www.ibiblio.org/gentoo/distfiles/kde-i18n-gentoo.patch"
kde-i18n_src_unpack() {
unpack ${A//kde-i18n-gentoo.patch} || die
cd ${S}
- patch -p0 < ${DISTDIR}/kde-i18n-gentoo.patch
- echo Please ignore possible errors about rejected patch above
+ if [ -f "docs/common/Makefile.in" ]; then
+ patch -p0 < ${DISTDIR}/kde-i18n-gentoo.patch
+ echo Please ignore possible errors about rejected patch above
+ fi
}
EXPORT_FUNCTIONS src_unpack \ No newline at end of file