summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-09-27 09:16:32 +0000
committerMart Raudsepp <leio@gentoo.org>2008-09-27 09:16:32 +0000
commit2ce7bee9a0ec2435bebf40c217a97f6f21a8d458 (patch)
tree08fd2adf7169fbaddd763f3a6e65b6ae092ddb50 /eclass/gnome2-utils.eclass
parentAutomated update of use.local.desc (diff)
downloadhistorical-2ce7bee9a0ec2435bebf40c217a97f6f21a8d458.tar.gz
historical-2ce7bee9a0ec2435bebf40c217a97f6f21a8d458.tar.bz2
historical-2ce7bee9a0ec2435bebf40c217a97f6f21a8d458.zip
Sort the list of Makefile.am and Makefile.in files used in gnome2_omf_fix(), so that
it is ensured the .am one is listed before the respective .in for maintainer mode regeneration to not kick in due to modtime of .am being newer than .in and the listed files being possibly patched with sed for a scrollkeeper fix. This maintainer mode build file regeneration is reliably reproducable only if PORTAGE_TMPDIR is on a filesystem with jiffies-granularity timestamps - tmpfs in particular. In the common case (ext3 and reiserfs) it is only second-granularity and GNU make rule dependency for am--refresh doesn't trigger almost never because the timestamp is equal unless it hits a second boundary pretty exactly in the middle. This should fix bug 236649 and all the few dozen INVALID bugs Diego Pettenò has filed against GNOME packages that claim the maintainer mode rebuild is caused by patches in $FILESDIR, while it must have been simply the omf_fix combined with tmpfs usage.
Diffstat (limited to 'eclass/gnome2-utils.eclass')
-rw-r--r--eclass/gnome2-utils.eclass6
1 files changed, 4 insertions, 2 deletions
diff --git a/eclass/gnome2-utils.eclass b/eclass/gnome2-utils.eclass
index 3b5085ef3618..e7b97814e7bd 100644
--- a/eclass/gnome2-utils.eclass
+++ b/eclass/gnome2-utils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gnome2-utils.eclass,v 1.10 2008/03/22 17:30:11 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gnome2-utils.eclass,v 1.11 2008/09/27 09:16:32 leio Exp $
#
# gnome2-utils.eclass
@@ -179,7 +179,9 @@ gnome2_omf_fix() {
fi
# testing fixing of all makefiles found
- for filename in $(find ./ -name "Makefile.in" -o -name "Makefile.am") ; do
+ # The sort is important to ensure .am is listed before the respective .in for
+ # maintainer mode regeneration not kicking in due to .am being newer than .in
+ for filename in $(find ./ -name "Makefile.in" -o -name "Makefile.am" |sort) ; do
omf_makefiles="${omf_makefiles} ${filename}"
done