summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-21 17:53:08 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-21 17:53:08 +0000
commite85d8224f9217e9e50ba589b1d2a76aad9bbb682 (patch)
tree1ef0f096e6131885b5a46edc6adc8a82233aa738 /eclass/autotools.eclass
parentMarking php-5.3.13 ppc for bug 414553 (diff)
downloadhistorical-e85d8224f9217e9e50ba589b1d2a76aad9bbb682.tar.gz
historical-e85d8224f9217e9e50ba589b1d2a76aad9bbb682.tar.bz2
historical-e85d8224f9217e9e50ba589b1d2a76aad9bbb682.zip
run intltoolize when IT_PROG_INTLTOOL is in use #416789 by Markus Oehme
Diffstat (limited to 'eclass/autotools.eclass')
-rw-r--r--eclass/autotools.eclass12
1 files changed, 8 insertions, 4 deletions
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 24095c90f4b9..f85b2dbafeab 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.139 2012/05/21 17:40:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.140 2012/05/21 17:53:08 vapier Exp $
# @ECLASS: autotools.eclass
# @MAINTAINER:
@@ -165,8 +165,10 @@ eautoreconf() {
# Run all the tools before aclocal so we can gather the .m4 files.
local i tools=(
# <tool> <was run> <command>
- gettext false "eautopoint --force"
- libtool false "_elibtoolize --install --copy --force"
+ gettext false "eautopoint --force"
+ # intltool must come after autopoint.
+ intltool false "autotools_run_tool intltoolize --automake --copy --force"
+ libtool false "_elibtoolize --install --copy --force"
)
for (( i = 0; i < ${#tools[@]}; i += 3 )) ; do
if _at_uses_${tools[i]} ; then
@@ -220,9 +222,10 @@ _at_uses_pkg() {
egrep -q "${args[@]}" configure.??
fi
}
-_at_uses_gettext() { _at_uses_pkg AM_GNU_GETTEXT_VERSION; }
_at_uses_autoheader() { _at_uses_pkg AC_CONFIG_HEADERS; }
_at_uses_automake() { _at_uses_pkg AM_INIT_AUTOMAKE; }
+_at_uses_gettext() { _at_uses_pkg AM_GNU_GETTEXT_VERSION; }
+_at_uses_intltool() { _at_uses_pkg IT_PROG_INTLTOOL; }
_at_uses_libtool() { _at_uses_pkg A{C,M}_PROG_LIBTOOL LT_INIT; }
# @FUNCTION: eaclocal_amflags
@@ -460,6 +463,7 @@ ALL_AUTOTOOLS_MACROS=(
AC_CONFIG_AUX_DIR AC_CONFIG_MACRO_DIR
AM_INIT_AUTOMAKE
AM_GNU_GETTEXT_VERSION
+ IT_PROG_INTLTOOL
)
autotools_check_macro() {
[[ -f configure.ac || -f configure.in ]] || return 0