summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-06 19:39:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-06 19:39:15 +0000
commit3ef61ed0bac35b3831858eb3c2a2779f4ed0636c (patch)
tree1c94b87d9f3be14bcc6a44a24c446f85dc2eb251 /dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild
parentVersion bump (diff)
downloadhistorical-3ef61ed0bac35b3831858eb3c2a2779f4ed0636c.tar.gz
historical-3ef61ed0bac35b3831858eb3c2a2779f4ed0636c.tar.bz2
historical-3ef61ed0bac35b3831858eb3c2a2779f4ed0636c.zip
Use Python 2 (bug #329483).
Package-Manager: portage-2.2.0_alpha29_p10/cvs/Linux x86_64
Diffstat (limited to 'dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild')
-rw-r--r--dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild b/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild
index 5c763aa573ef..48d1cd524da6 100644
--- a/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild
+++ b/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild,v 1.1 2010/06/19 16:19:58 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20090515.ebuild,v 1.2 2011/04/06 19:39:15 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit eutils distutils
@@ -23,17 +26,16 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${PN}"
DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+PYTHON_MODNAME="gitosis"
pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
enewgroup git
enewuser git -1 /bin/sh /var/spool/gitosis git
}
-src_compile() {
- pwd
- distutils_src_compile
-}
-
src_install() {
distutils_src_install
keepdir /var/spool/gitosis
@@ -46,5 +48,6 @@ src_install() {
#}
pkg_postinst() {
+ distutils_pkg_postinst
einfo "If you need to actually use gitosis, you must unlock the git user."
}